Problem recording "what you hear" on Win7Pro 64-bit

  clemenzina 23:10 PM 01 Jun 13

Whilst Googling my problem I noticed a knowledgeable reply on here to a different audio problem so am hoping that the expertise is still around :)

I have successfully recorded webcams on 4 different note/netbooks running Windows 7 Home Premium, 32- and 64-bit, which I think all had Realtek audio - but now:

Dell Precision M4400 notebook || Windows 7 Professional 64-bit || IDT High Definition Audio Codec

There is no StereoMix from which to record "what you hear", therefore RecPlayback has to be used. This means that if I lower or mute the volume coming from the internal speakers (so's to watch TV or listen to radio whilst the recording continues) the sound on the resulting recording also has low or no volume.

I "solved" this temporarily by plugging an external speaker into the headphone socket and using its volume control, but I do not want to use an external speaker.

Things tried:

-Attached clip-on USB speakers, then I get no sound at all.

-Ordered a USB sound card, it's in the post and I've now discovered that it will only operate with external speakers (scream!) why didn't they say that in the reviews I read?!

I have been advised to try "Virtual Audio Cable" but I see that the developer says "VAC behavior is similar to "What You Hear" (or "What U Hear", "Stereo Mix") feature of Sound Blaster Live! and Audigy cards. But it is only similar, not equivalent. If you simply need a function like "Stereo Mix" under Vista/Win7, it could be better to try to enable it in your audio adapter". The link he supplied was a Google search that is defunct.

In summary, what I want to do (as I could when my sound card had StereoMix) is record from the notebook's speakers and be able to adjust the volume in the room without affecting the volume on the recording.

I do hope someone understands what I'm getting at and can put me out of my agony :'(

  lotvic 01:27 AM 02 Jun 13

Dell, IDT, Stereo mix... as you have found out it's not there :( it's going to take some hunting to find one.

I had this problem and eventually found the one mentioned on Dell forum and it works for me, but I have XP not W7

  clemenzina 03:22 AM 02 Jun 13

Unfortunately XP is a pussycat compared to Win7, from what I have gathered. I may try again to install the old driver though, maybe I didn't do it quite right the first and second times!

I've installed VAC and found a very clear 'tutorial' on YouTube but it's for gamers to record game and own voice simultaneously, so he's linking sound input to VAC, I want to link output. Every time I adjust the procedure to speakers I lose sound altogether, but I haven't given up.

Thank you Lotvic, I appreciate your response :-)

  lotvic 15:12 PM 02 Jun 13

Have you tried the modded drivers from

I've got W7 on my alternative boot harddrive for this dell, haven't tried to sort the stereo mix out yet, but your thread has given me a nudge to get on with it.

  rdave13 16:00 PM 02 Jun 13

Have a look at this thread, dell forums, might work for you.

  lotvic 16:25 PM 02 Jun 13

rdave13, I think scyllabub posted on that dell forums thrread on 12 Mar 2013 5:04 PM - and has been using RecPlayback feature.

  rdave13 16:40 PM 02 Jun 13

Thanks lotvic. Didn't scroll down that far as it seemed to work for some. It's definitely finding a compatible driver, issue. Had similar problem with Win 7 but finding a Realtek alternative driver was easy compared to this.

  lotvic 17:35 PM 02 Jun 13

rdave13, I agree and this problem has always annoyed me with my Dell pc. Ancient IBM Thinkpad has no such problems and works with Audacity for Stereo Mix.

  clemenzina 21:58 PM 02 Jun 13

Thanks for all your replies. Yes, Lotvic, we have met before, is it pathetic that I can't let this go? Guess what, I've plugged the speaker back in ;-)

Just for info, I use Debut Video Capture to capture video and sound.

What is so galling about this is that my other Dell (Alienware) Windows7 laptops had StereoMix and they are newer than the Precision, so I had no idea that the problem existed and I set my heart on a Precision because of the HD display and sturdy nature of the machine. Thank goodness I didn't fork out even more £££ for the M4500!

I may have a retail copy of XP Home Premium in a drawer somewhere, but that seems drastic and what if it causes problems with network? Thinking aloud.

Lotvic, if you do get around to sorting it, and could tell me how so's I could understand, I would be SO grateful :-)

  BRYNIT 22:05 PM 02 Jun 13

You could try CLICK HERE it may help.

  clemenzina 23:12 PM 02 Jun 13

Thank you, Bryn, but that's for RealTek, the problem is with IDT High Definition Audio Codec.


Michael Marley said, re the driver he created, "These drivers should support the Rec. Playback (aka. Stereo Mix, Analog Mix, What U Hear, etc.)" - well, we know that RecPlayback does not equate to StereoMix, because you lose sound on recordings if you mute the speakers with RecPlayback but not with StereoMix.

Also the links are defunct on laura kk's post. But I have already tried to install a Sigmatel driver, failed. I may try again but had problems with leftover something-or-other, did a system restore to fix it.

Just letting you know that I am following up suggestions, so you don't think you are wasting your time on me ;-)


This thread is now locked and can not be replied to.

How to watch Rugby World Cup 2015 online: Watch live, catch up on-demand & stream the 2015 Rugby…

1995-2015: How technology has changed the world in 20 years

See immersive artist and storyteller Chris Milk speak at London VR event

What everyone thinks of the new Steve Jobs movie | 21 Facts about the Steve Jobs film | PLUS:…