Problem reading "Games for Windows" discs

  Caddy06_88 22:24 06 Oct 08
Locked

So I picked up Crysis today, installed the game and everything was working fine. I then tried to patch the game, 1.1,1.2 and 1.2.1, and then a strange problem started happening. Basically, my PC just stopped detecting the disc. Everytime I would try and load the game up, it would come up telling me to insert the original Crysis disc, which is already in the drive.

I then tried to play another game, Command and Conquer 3, and it worked fine. And then I tried Civilization 4 and I experience the same problem as the Crysis disc, and the link is they are both Games for Windows discs. So I un-installed Crysis and everything to do with it, deleted the patches and even done a System Restore, but the problem is still here, and I can't install Crysis again.

I can't really find any info on this kind of problem, and I am getting rather annoyed. If anybody has any idea, I would greatly appreciate a response.

Thanks.

  GaT7 01:27 07 Oct 08

Quite a few experiencing the same problem click here.

Known errors with the updates with possible solutions to some of them click here. G

  Caddy06_88 13:12 07 Oct 08

For the disc error problem, it suggests I turn off any virtual tools and start again, but I don't have any virtual tools.

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now