Problem pcmcia Slot

  Madpad_001 14:49 07 May 07
Locked

Hi,

I have a old Laptop (Win 2000)with no USB slots on it. But it does have a pcmcia slot but this does not seam to be working.

I installed a NEC pcmcia 4 port USB 2 card into the slot, the laptop said "found new hardware" then nothing. Looked in dvice manager and it says it is working fine but when I put a usb stick into the card nothing, no power to my stick.

So I am a little lost any any help will be most welcome.

  woodchip 15:11 07 May 07

My PCMCIA is also faulty like yours, but I made a Wood Wedge and put it in the back edge of the PCMCIA card so it presses it toward the front, and it makes it work. I first tried it with a thin screwdriver Only pushed in about half to three quarters of a inch

  Madpad_001 06:39 08 May 07

Thanks,

Tried that but no joy. (:-() It is like there is no pwr going to the PCMCIA card.

  Madpad_001 06:41 08 May 07

Thanks,

Tried that but no joy. (:-() It is like there is no pwr going to the PCMCIA card.

  PP321 07:29 08 May 07

These cards allmost ALLWAYS require a seperate power source. Is there a power socket on the card?

Also its likely a 16bit port , and the card may be 32 bit which can cause problems.

  woodchip 10:04 08 May 07

Mine as a socket on a Firewire card, but it does not need it to work. And my Wi-Fi card does not have a socket

  Madpad_001 10:28 08 May 07

There is no pwr socket that I can see on it. Just 4 USB Ports

  Madpad_001 10:32 08 May 07

I have plugged it into a XP Laptop and it works fine so am well lost

  woodchip 13:40 08 May 07

Get a torch, look inside the slot to see if you have a bent pin at the bottom

  Madpad_001 18:16 08 May 07

Good Idea will try

This thread is now locked and can not be replied to.

LG G6 review: Hands-on with LG’s bold, big-screen shot at perfection

1995-2015: How technology has changed the world in 20 years

How the 2017 Oscar-winning VFX of The Jungle Book were created

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…