Problem with Gmail spellcheck

  Pineman100 18:10 02 Apr 10
Locked

A friend of mine who lives in France uses a British Dell laptop. He does all his computer stuff in English, and runs a Gmail email account on Google .co.uk.

He has just has his computer upgraded to Windows 7 Home Premium (from Vista HP) by a French computer engineer. Ever since this upgrade, he's had a problem with the spellcheck function in Gmail (running in Firefox).

Whenever he types an email in English, virtually every word has the red underline, indicating that spellcheck thinks it is mis-spelled.

According to Google's help page "Gmail's spellchecker operates in the same language you've selected for your interface".

You can select another language for spellcheck to use, but this only remains in force until you restart Gmail - the idea being that you can spellcheck foreign language text on occasions. But afterwards this setting will always revert to your default language.

I've asked him to check that his computer's default input language is English (UK). It is.

I've asked him to check that Firefox is set to display pages in English [en]. It is.

I'm pretty sure that the reason for this problem is that the French computer engineer who installed W7 has left some setting which defaults to French - hence Gmail's spellchecker thinks that all English words are a mis-spelling. But I can't think what other settings might be affecting this.

Any ideas, please?

  mgmcc 22:54 02 Apr 10

Just a thought, but has he installed the "British English" dictionary add-on in Firefox?

  Sea Urchin 23:10 02 Apr 10

He could type a couple of sentences in French to test your theory.

  Pineman100 13:27 03 Apr 10

Sea Urchin - thanks for that suggestion. I asked him to do this, and it seems that spellcheck likes the French. So I think the theory is correct.

mgmcc - I'm still a relative newcomer to FF myself. Please could you tell me where to find that add-on, and what its effects might be? Does it act like a Firefox spellcheck (as opposed to Google spellcheck)?

  Sea Urchin 13:41 03 Apr 10

Just in case mgmcc is "off duty" at the moment

click here

  Pineman100 14:09 03 Apr 10

Thanks, Sea Urchin. That's useful.

I'm a bit in the dark about Firefox's spellchecker. I can find an option to "Check my spelling as I type" in Tools>Options>Advanced>General. But is there anywhere in FF where I can check to see what language FF spellchecker is using? Or does it automatically use the language specified in Tools>Options>Content>Languages?

  Sea Urchin 14:20 03 Apr 10

This is a list of all available dictionaries

click here

Then you can go to Tools - Add Ons and remove the French dictionary - then install the new one. This thread gives you the picture

click here

  Pineman100 15:58 03 Apr 10

I've carefully read the thread that you linked to, and I'm now even more convinced that it's the Firefox spellcheck that's causing my friend's problem.

I'll brief my friend on this, and post again when (if?!) we reach a solution.

Many thanks for your help.

  Sea Urchin 17:07 03 Apr 10

Thanks - will be interested to know the outcome.

  Pineman100 19:13 05 Apr 10

Hust to update you - I've sent some instructions to my friend in France, telling him how to disable his Firefox spellcheck.

I didn't venture into the subject of dictionaries yet, because he's far from computer-literate and I don't want to confuse him. I thought that if I got him simply to disable FF spellcheck, we could see whether the red underlining disappeared. This would then tell us whether FF spellcheck is definitely the source of the problem.

I'm waiting to hear back from him.

  Pineman100 19:14 05 Apr 10

Oops! Hust = just

This thread is now locked and can not be replied to.

AMD Ryzen release date, specifications and features: Three CPUs from the Ryzen 7 range now…

1995-2015: How technology has changed the world in 20 years

Glassworks Barcelona shows how it captured the artistic imagination of Conor in A Monster Calls

Best iPhone games 2017 | Best iPad games 2017: 162 fantastic iOS games that you need to play right…