Problem with DNS Server behind NAT

  Jaymz87 13:43 28 Feb 05
Locked

hi everyone,

i've recently been trying to set up a DNS Server, which to a point has been successful, depending on how you define successful when it comes to DNS behind a router with NAT.

What happens is...
I've given out my DNS address to my friends, I don't really want to give it out here, as it points to my Routers setup page :)
Anyway, I'm using DynDNS.org with a Dynamic DNS Hosting service, I am giving it my public IP address, which I assume is pointing to my LAN IP which leads to my Router config page.

I am using Microsoft IIS (although not very powerful, it allows me to do everything I need with ASP .Net) and before I had my router, it worked fine. Now I have my router, IIS is only finding my LAN IP (192.168.1.x) but my public IP address is currently 81.154.48.158 (btw, this changes every 5 mins or so, and I am using NetSoft DynDNS Client to automatically update it on DynDNS.org). When I set DynDNS.org to point people to 192.168.1.4, they can't get to it, which is fair enough, as that is the private LAN IP, and when I give people my public IP address (whatever that happens to be at the time) they get directed to my router set up page, and not the site that is on IIS.

I know thats quite a long winded explanation, but it seems to be quite a puzzling problem, unless I'm missing something really obvious. I'm usually on the other side of these forums giving the help, so I know that if there is someone on here that knows the anwser, they'll help, so thanks in advance.

  Jaymz87 13:49 28 Feb 05

Don't know if this helps anyone come to a conclusion, but it doesn't matter if IIS Service is started or not, it still goes to my router setup page.

So is it just a case of somehow bypassing the router page?

  Jaymz87 15:34 28 Feb 05

bump

  Jaymz87 17:37 28 Feb 05

i have sorted this out now, but i thought i would let others know how i sorted it.
It's not really an ideal solution, but it works, you have to use DMZ, not sure what it stands for, but it means taking your PC outside the firewall or something. lol.
It is contained somewhere in your router setup pages, not sure if this is for all routers, but for BT Voyager routers, go to click here and that will take you to the setup pages. Go to the advanced options, BT username and password are both admin (very secure, eh?) then setup a rule for NAT/DMZ for your PCs LAN IP.

  bretsky 17:49 28 Feb 05

Glad you sorted it out and thanx for letting us know.

bretsky ;0)

This thread is now locked and can not be replied to.

New Google phones UK release date | Pixel XL price, new features, specifications: Pixel X and…

1995-2015: How technology has changed the world in 20 years

This is the future of TV, VR and holograms

iPhone 7 review: Enhanced cameras, a refreshed design and water resistance make the iPhone 7 an…