Problem with ati2dvag - Infinite loop

  Sea Urchin 11:20 11 Dec 10
Locked
Answered

I have recently had to run a clean reinstall of Windows (XP Pro) which went without a hitch. However, I now appear to have a problem with the graphics card driver. As I am working the system will freeze, and then switch off to a blue screen.

The message states: There seems to be a problem with the file ati2dvag - the device driver got stuck in an infinite loop - this could be a problem with the device itself or the driver.

STOP: 0x000000EA (0x88D91020, 0x89B4D1BO, 0xF78C6CBC, 0x00000001)
at ati2dvag
Beginning dump of physical memory.

I don't think there is any problem with the card itself (ATI Radeon HD 2600 PRO) as when I remove the driver and run on the generic Windows driver everything works beautifully. Naturally the display is restricted but is very crisp - and the computer runs faultlessly. As soon as I replace the driver it runs for a few moments and then cuts out again.

There are many reports of this behavior via a Google, but no solution that seems to work. Any thoughts from you experts out there?

  GaT7 15:20 11 Dec 10

Try only installing the ATI drivers (leave out Catalyst & other things).

Also try the ATI Omega drivers click here. G

  GaT7 15:25 11 Dec 10

While you're there, it wouldn't hurt to install the latest DirectX 9.0 version click here before installing the drivers. G

  Sea Urchin 16:26 11 Dec 10

By no means the first time you have helped me out with graphics cards - I'm very grateful.

I had tried installing just the driver without Catalyst but that didn't help. I shall now try your other suggestions and report back.

  Sea Urchin 21:45 11 Dec 10

Installed the DirectX 9.0 OK - and then the Omega driver - but still shut down. Certain sites seem to cause a problem - the download site CNET is one such.

Have now tried reinstalling the solo ATI driver (although a certain amount of Catalyst stuff also installs) as I previously didn't have the DirectX installed.

Fingers crossed.........

  Sea Urchin 00:13 12 Dec 10

Did shut down again after half an hour - so once again put in the Omega driver. Now been running for two hours without a problem. Will see how it goes tomorrow.

  Sea Urchin 10:51 12 Dec 10

Didn't last 5 minutes before crashing this morning, so back to the basic driver. Everything runs OK like this, despite looking a little odd.

I don't know whether another reinstall might achieve anything? I certainly had no driver problems before the reinstall.

  Terry Brown 11:16 12 Dec 10

Try this

reboot the machine in SAFE mode (try F5)

select VGA mode (If Available)

This will boot your machine with NO graphic drivers (very low resolution- 4 colours).

Now insert your graphics CD (or load your drivers from where ever they are). When finished Reboot.

This will perform a clean install of all your graphic drivers and should clear any problems.

just a thought, does this card have it's own fan (and power supply), as it may be overheating, if these are obstructed in any way

Terry

  Sea Urchin 17:11 12 Dec 10

Went into VGA mode and then tried installing the driver waiting on desktop (no CD available). Because of size of display I couldn't access the lower parts of the windows. Then tried via Device Manager, but despite my best efforts to point at the desktop driver it seemed to install from its previous incarnation.

Ran fine for a while, so I then tested it by going to the CNET downloads page - immediately it froze and closed down.

Had a look at the card and all seems fine. So now back on disabled driver where it will run happily for ever. At least it enables me to work.

  GaT7 17:34 12 Dec 10

This worked click here for poster 'caroux' & others apparently, but don't suppose you have a 'CPU to AGP Controller' in Device Manager, do you?

You can also try older drivers, but may be one or two only, otherwise you could be at it for a very long time! The ATI driver archive is at click here. G

  Sea Urchin 19:00 12 Dec 10

Yes, I do have CPU to AGP in Device Manager - and it was one of the first "fixes" I tried- from another website but the same.

I tried to install an older driver (2009) from your list (having uninstalled first) and somehow it insists on installing the latest driver.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac