Printing difficulties via USB (Hub)

  aca 18:09 18 Feb 09
Locked

Have just has to replace a faulty (cheap) USB hub. New one is a Belkin 4 port hub.

Having an annoying glitch with the printer that connects through this to the laptop.

The printer appears faded out in Control Panel, and will only work if I unplug the USB going into PC. Despite the fact that the printer def installed the found new hardware message comes up and reinstalls (but also comes up with not having Administrator rights to run the programme).

The printer then works.

I had no problems with the previous Hub.

Is solution to uninstall the printer, and then reinstall obviously using the hub connection?

(running XP Pro and the printer is a HP laserjet 2605dn)

thanks

  aca 20:58 18 Feb 09

b

  Stuartli 23:01 18 Feb 09

Using USB printers, scanners etc is best done with a direct USB connection to the system, rather than through a hub.

  bluto1 23:01 18 Feb 09

Hi there,
The only thing I can think of is that you unplug your 4 way usb hub, and plug the printer directly into your computer. I've had similar problems in the past and worked through a trial and error system to solve the problems. Mostly they've worked. Give it a go.

  bluto1 23:05 18 Feb 09

You obviously don't have arthritic fingers, well I hope not!!!! :-))

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac