Printer stopped working

  thumbscrew 01:13 13 Feb 07
Locked

I have an Epson C48 printer that's never given me any trouble....UNTIL TONIGHT!. I used it to print a web page and it did it perfectly. Tried again a few minutes later,the options box appears, but when I click on print, nothing happens.
I've uninstalled and reinstalled the drivers but still no joy. Can anyone help?

  STREETWORK 07:21 13 Feb 07

I take it you have checked the obvious, cable, printer to PC lead, fuse at plug, its plugged in...

Are the lights working or flashing?

If they are steady (green) go into control panel, printers and faxes, select the printer, right click, select properties,from there print a test page.

No test page, or error messages. Uninstall the printer from control panel and then reinstall it by selecting 'Add Printer', follow the wizard and let windows reinstall the driver.

If you get a message that the printer needs resetting , click here

Post Back results

  thumbscrew 14:27 13 Feb 07

Streetwork, thanks for fantastic response. Just after I posted,I noticed a small box in my toolbar which said..."You have pending printing messages"..or such like.
When I clicked on it, there were all the pages I had been trying to print,I know not how but,somehow they were "stuck there"
I cancelled them and it then began to print. However I will keep your instructions in case of further problems. Thanks again pal.

  STREETWORK 08:02 14 Feb 07

No worries...

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now