Printer problem-communication error

  bison 14:17 21 Oct 03
Locked

I am trying to get a printer (Epson stylus colour 660) to work on my kids computer, but when I use anything to print with e.g.word or paint shop pro etc, an error message comes up stating there is a communication error, suggesting to check the cables etc.This does not happen when I do a test page as that prints out perfectly.I have reinstalled it, changed the cables with my printer(and the cables work),I have checked for new drivers and nothing seems to work. Any ideas....?
Thanks in advance.
Bison.

  DieSse 14:23 21 Oct 03

Check in the BIOS that the parallel port is set to ECP mode - this is what Epson and HP both recommend.

  bison 14:47 21 Oct 03

Sorry I forgot to mention, I am a bit of a novice/thicky with regards to computer jargon/talk, but I do know the basics of computers if this helps.
and BIOS is.....?
I have checked on the printer details and this states Print to the following port- LPT1:(ECP Printer Port).
Does this help

  DieSse 15:00 21 Oct 03

It looks like it might be - but to check - when the computer first is powering up, keep tapping the Del key. This should get you into the BIOS (just a set of stored settings about the computer).

Then get to the page (using the arrow/enter keys) that has the parallel port settings on it. If it already says ECP, then leave it alone - if not change it (it'ss indicate how).

  bison 15:23 21 Oct 03

Nothing happens- it just boots up as normal.
Does it make a difference being on Microsoft ME?

  wx622 15:33 21 Oct 03

Sorry to butt in, but I ask if you have your motherboard manual. This will tell you how to get into the bios settings on your PC. Most of the time, sometime in your bootup these instructions are given. To be given more time to see what is being brought up on the screen you can press Pause/Break on your keyboard. Normally, the POST (power on self test) when you switch your PC on will test your parallel port for problems. But when you find out how to access your bios, check that on your 'Integrated Peripherals' (or similar) the resources for the Parallel port are set to "378/IRQ7".

  woodchip 15:47 21 Oct 03

Go into Start/Settings/Printers and Right click on you Printer and choose "set as default"

  woodchip 15:48 21 Oct 03

Check the obvious first

  bison 11:48 25 Oct 03

My humblest apologies for not answering back sooner but "she who must be obeyed" wanted some jobs doing.I hope you guys are willing to take some more of your time in helping me.
I have managed to get into CMOS (if that is the same as BIOS) and checked everything you guys have stated and the settings are exactly as you have indicated.I printed another test page and it printed perfectly ( no gaps, all colours), checked the ink levels which are ok, then tried to print a small word doc. and the same message comes up- communication error.
Any other ideas....?
Again thanks in advance.

  Spencus 12:53 25 Oct 03

try this check,

open control panel,left click printer icon,right click epson icon-click on properties,then details....The "print to following port"box should read...LPT1:(printer port)

The "print using following driver" box should read..Epson Stylist 660. if not uninstall,and re-install folling to sequence in the Epson manual.

  bison 13:03 25 Oct 03

Sorry Spencus, already checked that (but thanks anyway) and have also reinstalled it, checked up to date drivers, all the obvious things I can think of but to no avail.
The thing that is puzzling me is why it's printing a test page correctly but nothing else?
bison.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac