Printer problem

  jessej 16:07 22 Jun 05
Locked

I have two computers, both running XP Home, and two printers, one a Lexmark X84 and one a cheapie Dell.
The Lexmark is, or was, connected to my main PC. I have been having trouble with it for about a week, namely very slow in starting to print. Lexmark Tech Support have come up with various suggestions/tests which the printer passed but it did not cure the problem. Yesterday it stopped working altogether and I had to go into Task Manager to shut it down, the usual message - not responding. Today I carried out a little excercise and swopped the printers round, both worked perfectly so I changed them back again. Result the Lexmark would not work on my main PC.
I'm completely stuck for ideas now. To summarise, the Lexmark will only work on my other computer, not my main computer whereas the Dell will work on both.
Any suggestions gratefully received.

  woodchip 16:19 22 Jun 05

Some Printer files have been changed. May be by the last printer you installed but if its a USB the usb item can play funny ricks with files and registry

  woodchip 16:22 22 Jun 05

One suggestion is Go into Device Manager down to USB if they are USB, expand the USB list and starting from the bottom uninstall all root hubs then restart for windows to reconfigure the USB

  mickja 19:04 22 Jun 05

it might be something as simple as default settings.have you set the dell printer as the default printer on both systems

  jessej 19:12 22 Jun 05

Woodchip. Done that but no difference, the Lexmark still won't perform on my main Pc.

Mickja. While I was trying to use the Lexmark it was set as the default, in fact, it was the only printer installed when it died. When trying to use the Dell I set that as default and it worked perfectly.

I must admit that I have been suspecting USB port trouble for some time. One example, not connected to this problem, is my DSL modem. I often have to unplug the USB cable then plug it back in again to get it to work. Is there any way to test these ports other than calling in the experts?

  mickja 19:37 22 Jun 05

had the same problem with my usb connection anything i plugged in came up as a disc drive .only way to resolve it was to buy a new usb card

  mickja 20:02 22 Jun 05

have you tried going through start>c/panel>printers>properties>advanced and activate PRINT DIRECTLY TO PRINTER Click apply and try printing if this works you need to fix the print spooler?

  wiz-king 05:28 23 Jun 05

have you got any other USB devices running? You mention the modem? It may be that the USB ports cannot supply enough power to support all the devices, try putting the printer on a powered hub. Printers can take a lot of power as they get older and full of dust, if you can get at the slide bar(s) give it/them a wipe over and a thin film of light oil, this may reduce the power consumption enough to make it work.

  jessej 08:59 23 Jun 05

Thank you all for your replies, unforunately I've already tried them all without success.
The only other USB device connected is a BT Voyager 105 Modem. One thing strikes me as strange though, both are shown on the same USB Root Hub, the other three don't show anything connected, is this right? If not then how do I separate them? They are, of course, plugged into different ports.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…