Printer error

  Terrygee 09:03 06 Aug 10
Locked

I'm using Vista Home and an Epson Stylus C86 printer.
In every session the printer fails to print the first page. The icon shows one document in the queue. I "open all active printers" and "delete all documents", answering "yes" to "am I sure". The message changes to "delete" but doesn't delete. So I repeat the steps, and on the second occasion deletion takes place. I switch the printer off, them back on. Printing will then work and continue to work throughout the session. How can I get it to work first time?

  gengiscant 09:13 06 Aug 10

Do you have the latest Vista driver for your printer?

  Terrygee 14:24 06 Aug 10

Oops, I didn't know that there was a later driver. I'll give that a try. Thanks for the advice

  gengiscant 10:41 07 Aug 10

Actually I do not think there is a Vista driver for what is quite an old printer.

  robin_x 00:45 08 Aug 10

My Canon Pixma MP250 just gave me gip after 4 months of trouble free.

Upstairs PC said "online" downstairs laptop said "offline"

Adding the printer again in "Devices and Printers" worked temporarily. Or restarting the spooler.

(Run services.msc)

But it still failed after every night shutdown.

Tried reinstalling my network printer.

It seems to be fixed after removing it and Add Printer.

W7 Home here.

This thread is now locked and can not be replied to.

What is ransomware and how do I protect my PC from WannaCry?

Disney layout supervisor Rob Dressel on the challenges of visualising Moana

Siri vs Google Assistant