coolteentom 16:35 10 Mar 04


I have just stupidly renamed a vital foler (Iosubsys) @ c:\Windows\System\IOSUBSYS. When I try starting tye computer, it says

While initialising device IOS: Error: An I/O subsystem driver failed to load. Either a file in the .\iosubsys subdirectory is corrupt or the system is on low memory.

Is there anyway I can rename this folder back again, (or perhaps use the recovery diskette to Restore System Files???

Thanks for your help, tom

  JerryJay 16:43 10 Mar 04

start on safemode and try again, just a thought.

  temp003 16:47 10 Mar 04

If that doesn't work, try booting up with a boot floppy, and at the A:\> prompt, try the following:

ren c:\windows\system\[new folder name] iosubsys

and press Enter. Restart.

  coolteentom 17:00 10 Mar 04

thanks for replies - have tried running safe mode, but just comes up with error message.

Have tried going ren c:\windows\system\bootup\iosubsys, and get 'Required Perameter missing'

Any other ideas

thx, tom

  coolteentom 17:39 10 Mar 04

Sorry - was a bit confused.

I have put in:

Ren C:\Windows\System\Iosubsys2 Iosubsys

and I get 'File not found - C:\Windows\system\iosubsys2

I guess this suggests that I did not rename it to Iosubsys.

I have tried the 'DIR c:\windows\system' command prompt, but it goes to fast.

I have tried the 'DIR c:\windows\system\iosubsys2', and there was no File Found..

  coolteentom 17:41 10 Mar 04

sorry - i meant--

I guess this suggests that I did not rename it to Iosubsys2 (with the 2).


  coolteentom 17:45 10 Mar 04

What could help, is if I could go through all the files in c:\windows\system SLOWLY so I can see all the files, and see if I can find what I did rename it to.

Any ideas?

Thanks for ure help


  Big Elf 17:50 10 Mar 04

dir /p will pause on each screen.

  Big Elf 17:52 10 Mar 04

dir /w will show a lot more folders and files but may still be tto fast. Note that there's a space between dir and the switch (/).

  coolteentom 18:09 10 Mar 04

Thanks for the tips Big Elf,

I have found [IOSUBSYS~1] and will try renaming that

  coolteentom 18:15 10 Mar 04

I have renamed the IOSUBSYS~1 to IOSUBSYS and the system has successfuly booted up.

Thanks for all your help!

Tom :)

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…