Philips desktop

  zant 21:20 20 Apr 15
Locked

I recently had an interesting fault on my Vista 32 Bit 8 year old Philips HEPC 7511/05.

Booting up it would go into repair mode but would not repair.

Booting into safe mode and looking at Device Manager indicated the NVIDIA Ge Force 8500 GT was not working.

Downloading current drivers from NVIDIA website did not cure the problem so I reverted to my Royal Signals training, which advised that connectors must always be suspected first.

Prior to diving inside the case ensure it is earthed but disconnected from the mains, and discharge yourself by using a wrist band or regularly touching the earth point.

Removing the card, the connectors looked ok but to play it safe I cleaned the connectors with Servisol Aerosol Switch Cleaner, and also sprayed the MoBo female connector, followed by several fittings of the card to the MoBo, after which an application of MS4 Silicone Compound to the card connectors, followed by more fitting and removal of the card. The layer of silicone must be very thin and use of a lint free cloth is advised to spread the grease finely.

Hey Presto, switching on and my 8 year old booted up like a charm. With that I gave all the other cards the same treatment, cleaned up the dust with a vacuum and several weeks later all is still well.

Silicone compound or grease and Servisol switch cleaner is available from RS Components, Amazon or Maplin. A worn out tea towel is a good source of lint free cloth.

I wonder how many other faults could be cured or prevented with a connector wash and brush up?

  Fruit Bat /\0/\ 22:30 20 Apr 15
  1. Boards work loose due to exothermic cycling as PCs heat up and cool down

  2. Contacts oxidise overtime

Quite often a simple remove and refit is enough to remake the connection and solve the problem.

As you suggested contact cleaner helps as well.

  zant 11:29 21 Apr 15

Hi Fruit Bat,

Thanks for your comments. There was no evidence of loose boards, but I have had another look to check quality of plating, and there is no evidence of prior plating such as nickel before gold, which doesn't surprise me on a non MilSpec edge connector, and conributes even more to contamination.

Another point of interest being this computer came with Media Centre and TV Tuner. For some long time now I have had to reboot the tuner 2 or 3 times, after the switch cleaner and silicone treatment it now starts up ok every time.

This thread is now locked and can not be replied to.

Surface Pro 5 News - release date, UK price, features, specs

Microsoft Surface Studio hands-on review: the iMac killer is here

Best Mac antivirus 2017