Peer-to-peer wireless, why so painful?

  theonlyrick 23:59 26 Jun 06
Locked

Hi,

I'm trying to connect a laptop and desktop via an ad hoc network. Both have XP Pro and latest updates.

The network can be found on each computer, but I'm unable to browse either of the computer's hard drives or succesfully use ICS.

The annoying/good thing is that I did manage to get it working (without encryption) for an hour or so. But then I added encryption and bodged it up.

The laptop has an Intel Wireless card, the PC has an annoying "AshtonDigital AirDash", which uses annoying proprietary setup software. It's annoying (and I unjustifiably think is the route of all my problems).

First question, I guess: Should I restart either or both computers when I've made a change on one of them? Which changes do need restarts?

Also: Do I need to worry about with IP addresses with an ad hoc network?

Should I be pinging? If so, how?


Thanks very much,


Richard

PS - JIn an attempt to return the favour, here's a little-known tip: Hold down Ctrl on your keyboard and roll your mousewheel. Speedy zoom, huh?

  mgmcc 08:01 27 Jun 06

Both adapters need to be set to work in Ad Hoc mode, to be given the same SSID, the same type of encryption and the identical encryption key. Once this is all set up, try rebooting each PC in turn to see if it then "finds" the Ad Hoc network. It can be a bit of a pain to get it connecting initially but eventually seems to sort itself out!

When you enable "Internet Connection Sharing" on the Internet connection, it automatically configures the network adapter used for your "private network connection" with the IP address 192.168.0.1 and subnet mask 255.255.255.0. If you have more than one adapter available for this purpose, e.g. both a "Local Area Connection" and a "Wireless Network Connection", you will have a drop down list from which to select the appropriate adapter. The "Client" PC's Local Area Connection should be set to get its IP address automatically, which it does by DHCP from the "Host" PC. Also, if you run the Zone Alarm firewall in your "Host" PC, the Internet Zone Security level must be reduced from High to Medium or "ICS" traffic will be blocked.

Once your Ad Hoc network has established itself, the "client" PC should gets its IP address from the "host".

  theonlyrick 09:05 27 Jun 06

Thanks for your reply.

I think part of the problem is ensuring the encryption keys are the same - it's hard to tell because the Windows options and the options on the application supplied by Ashton with their USB WiFi gadget are so different.

I'll concentrate on those and get back to you. (But first to work, unfortunately...)


Cheers,

Richard

  ade.h 15:03 27 Jun 06

You should create your WPA-PSK in a text file first, then copy and paste it wherever it is needed. That avoids hassle and typos.

  theonlyrick 09:05 28 Jun 06

Thanks for the replies, no joy yet, though. I did a full un- and re-install of all hardware and drivers, with plenty of switching off inbetween.

I think the problem is translating the settings between the Windows and the Ashton wireless set-up dialog boxes.

I'll transcribe them to here to see if anyone can tell me what equals what on the two dialog boxes.

Thanks.

  theonlyrick 00:51 29 Jun 06

The Windows settings.

This shows what I have for "Network Authentication" and the context sensitive sub-menu options under "Data Enryption":

NA Open
DE Disabled
DE WEP

NA Shared
DE Disabled
DE WEP

NA WPA-None
DE TKIP
DE AES

Which of these settings is the equivalent of no security? (On the Ashton box there is a tick box to disable WEP encryption - easy!).

Once I've got that sorted, I'll move on to securing it...

Thanks.

  mgmcc 08:22 29 Jun 06

I'm not sure what those three lists represent, but if each one has to be configured, I would have thought you would set the first two to "Disabled" and the third to "WPA-None" to remove all encryption.

  theonlyrick 08:50 29 Jun 06

Hi,

There are two drop-down menus. The first is called "Network Authentication". This has three options, (Open; Shared; WPA-None).

As you go through these options, the sub-menu called "Data Encryption" changes.

Below shows what the options are available the sub-menu (DE), depending on what option is chosen in the main menu (NA).

-NA Open
--DE Disabled
--DE WEP

-NA Shared
--DE Disabled
--DE WEP

-NA WPA-None
--DE TKIP
--DE AES

So, my question is, which of these settings is the equivalent of no security? (On the Ashton box there is simply a tick box to disable WEP encryption - easy!).

Thanks,

Richard

  theonlyrick 08:52 29 Jun 06

This is the dialog box that has the menu options described above:

click here

  mgmcc 09:30 29 Jun 06

OK, set both Network Authentication and Data Encryption to Disabled.

  theonlyrick 11:17 29 Jun 06

That's the weird thing, there's no Disabled option for Network Auth.

There's only:
Open
Shared
WPA-None

I guess "Open" is disabled, but I wish they would call it that!

I'll stick with those settings. I'll follow this up tonight.

Ta,

Richard

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…