PCI 4 port + 1 USB2.0 problem

  Taw® 20:01 12 Sep 06
Locked

Have recently bought the above. Inserted into computer all seemed ok recognised card and all seems correct in device manager. However If I plug a usb device (any) into the ports it comes up as unknown device and no matter what I do it will not recognise any drivers. When I plug the devices into my onboard USB 1 they are recognised ok. Xppro plenty of ram intel etc. AS i say all works on my built in USB just not recognised in the PCI. Have tried reseating the card but no go

  ed-0 20:13 12 Sep 06

Make and model of card.

have you tried a different PCI slot?

  Taw® 20:21 12 Sep 06

No wil give that a go. As I say it seems to be recognised ok, but any devices being plugged in are not

  Taw® 14:45 14 Sep 06

the card is a safecom with 4 ports external and 1 internal I have tried other PCI slots but no joy

  Newuser4165 15:13 14 Sep 06

Your problem is with the card.
I've had 2 of these useless cards which have both failed within months.I suggest you send it back and purchase a different make.
I have found that the more expensive cards always work eg Belkin - there are other makes.

  Taw® 16:28 14 Sep 06

You get what you pay for Newuser4165 which is what I suspected, so many thanks of to purchase a new card

This thread is now locked and can not be replied to.

LG G6 review: Hands-on with LG’s bold, big-screen shot at perfection

1995-2015: How technology has changed the world in 20 years

How the 2017 Oscar-winning VFX of The Jungle Book were created

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…