PC won't install hardware!

  Fish 10:22 03 Jun 06
Locked

I have a Dell Dimension 8200 (1.6 processor 512Mb RD Ram) purchased from Outlet in 02. In 04 the parallel port ceased to function, but everything else worked fine until this April.
I tried to install a PCI USB2 card (the PC came with 1.1). The installation failed with the message: "Error, cannot install this hardware, data invalid". I assumed this was a component fault and was chasing it up with the maker, when I had need to re-install a Floppy Drive and got the same message. I have subsequently found I get the same result whatever hardware I try to install.
Anyone got a clue/cure?

  Fruit Bat /\0/\ 10:31 03 Jun 06
  Eric10 10:35 03 Jun 06

Same thing from Microsoft click here.

  Fish 11:46 03 Jun 06

Thanks for that; unfortunately it hasn't done the trick. I got a repeat of the "can't install hardware" message on both components of the USB2, and no message on the Floppy drive. All 3 still have the exclamation mark in Device Manager.
Any further thoughts anyone?

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Prehistoric Britain is laid out in these Royal Mail stamp illustrations

Best running headphones | Best sport & fitness headphones: 4 brilliant pairs of wireless…