PC won't connect to web, but email OK?

  Rodders 15:03 19 Nov 08
Locked

Hi
Hope someone can assist.
My home desktop PC has been fine for browsing the web for months. Suddenly, it has started having a problem.

It's running XP Home, connecting by wire to a router which is connected to my Virgin Media modem. It can happily connect to my Virgin email account and collect the emails and send them.

But Internet Explorer and Firefox are both refusing to function. No matter what web page I attempt to reach IE says "Cannot open the webpage" or words to that effect, and Firefox says "Connection Interrupted".

I tried renewing the IP address with 'ipconfig /renew' but this has no success.

Checked my Firewall settings and all seems to be fine.

I'm currently using my work's laptop wirelessly using the same router and it's fine, obviously.

This is a real head scratcher.

  Rodders 18:17 19 Nov 08

anyone any tips?

I've rebooted everything - PC, modem, router, even the set top box which shouldn't be relevant but I did it anyway!

I've managed to use FileZilla to connect to my web server's FTP account. So, the router must be OK, and the PC must be talking to it.....so it seems like a setting that's not right.....or maybe a port issue? I don't understand these things.

  User-1229748 18:50 19 Nov 08

what anti virus are you using?

  Rodders 19:00 19 Nov 08

AVG Free 8.0.175

It can't connect in order to do an update.

  User-1229748 19:10 19 Nov 08

i would be tempted to disable your anti virus just to see if it will access your home page,if that doesn't work disable your firewall just to see if you can open your home page.

  woodchip 19:16 19 Nov 08

I would say either Firewall or Hosts file is blocking Web from your PC. First check what is being blocked by Firewall Windows Firewall is notorious for blocking you from the Web, try turning it off in security Settings. I do not use one and been many years since I did. For hosts file click on Search type in box Hosts then double click the File for it to open, You will see all that it blocks

  bretsky 19:19 19 Nov 08

It's an AVG thing according to this click here read firefox users reply about half way down the page

bretsky ;0)

  Rodders 15:00 23 Nov 08

Hi
Thanks to those who have posted tips. I've just reinstalled AVG, and the problem still exists and did while AVG wasn't running.

I assume my PC isn't talking to the router correctly, but other than that I'm stuck.

Please help!?

  DieSse 15:31 23 Nov 08

Check in the connection setup and see if "proxy server" is ticked - if it is try unticking it.

I've seen three systems recently where that has happened, and as yet I can't account for why.

  Rodders 15:35 23 Nov 08

DieSse - checked that, and the tick is definitely not there.

  Rodders 00:41 24 Nov 08

OK, machine has miraculously fixed itself.....and now I have a new problem - there appears to be some kind of spyware which is stopping me from updating any of my AV or security products.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac