PC won't connect to internet

  JHHT 09:35 AM 03 Jun 12
Locked

I recently bought an Advent PC running Windows7 and connected it to a home network with other devices that have a mix of wireless and cable connections. All work fine with the exception of the new PC which is fine some days but on others it needs to be rebooted several times before it will connect to the internet. Today after numerous reboots including the router it stil won't connect.

I have rebooted the router and replaced the ethernet cable. Windows diagnostics can,t find any faults.

Any advice please?

  onthelimit1 09:42 AM 03 Jun 12

If others are OK, and the new one has problems connecting, it's either a driver problem, or the network card/chip has an intermittent fault, I'd say.

You could try downloading and installing the latest driver - look at Network in Device Manager to find out the manufacturer and model. If that doesn't work, I'd be tempted to assume it faulty and ask for an exchange.

Others may have other ideas, of course, so best wait for more responses.

  spuds 11:03 AM 03 Jun 12

Considering that some devices appear to be working and others do not, then it could be a number of things. What I would suggest is that you go to your ISP's website and see if they have an instruction setting-up page, and see if that suggest anything, possibly a few tick and apply boxes?.

My own ISP is very good at this, both on-line and via telephone support, but tend to fail on other things ;o)

  JHHT 12:31 PM 11 Jun 12

A quick update. I had a look for a new driver but the only one I could find was older than the PC so I didn't bother. I also contacted my ISP who considers that the problem is computer issue rather than anything to do with them.

I have found that if I disable the connection and then re-enable I can get a connection straight away. It's not an ideal solution but it is a big improvement. I have informed my ISP about this and perhaps I will get a further reply from them.

  Fruit Bat /\0/\ 13:00 PM 11 Jun 12

I have found that if I disable the connection and then re-enable I can get a connection straight away.

Check in device manager your network adaptor card - right click - select properties - power tab - ensure allow the computer to switch off ... is unticked.

Advertisement

This thread is now locked and can not be replied to.

How to get free stuff for Android: Amazon Underground offers genuinely free Android apps and free…

1995-2015: How technology has changed the world in 20 years

Swedish schoolkids use Minecraft to redesign Stockholm city centre

Apple's special event invitations decoded: A look back at 13 of Apple's most cryptic invites