PC Restarts - USB issue?

  Bobby237 16:42 25 Sep 05
Locked

Hi. I'm running Windows XP and recently bought a camera and USB card reader. Have tried to install both by connecting to USB and get problems. When I connect camera, it detects, then gets to "found disk drive" and PC just reboots. In event viewer, error - The General Purpose USB Driver (adildr.sys) service failed to start due to the following error: The system cannot find the file specified. Looked into this & found it could be related to Sagem USB modem. Tried various fixes including updating drivers for modem to no avail so fully uninstalled modem, then tried to connect camera & still got same issue which suggests modem isn't the problem. In event viewer, error had then changed to Error code 10000050, parameter1 ffffffe8, parameter2 00000001, parameter3 804d9079, parameter4 00000000. When I try to connect card reader, PC just slows down completely so I have to reboot. Was going to try camera/card reader on alternative PC to ensure these both worked ok but unable to do that at the moment. Tried disabling background progs & made no difference. I've got no idea what to check next, any suggestions? Thanks!

  woodchip 18:29 25 Sep 05

Look in device manager and uninstall the item with a yellow icon. you should have the cd ready when you have done this. Do not restart until you have run the setup on the cd to install drivers. When you put it in it should auto load. if not look for the setup file on the cd and double click on it

  Bobby237 22:22 26 Sep 05

There is nothing in Device Manager with a ! I have checked in safe mode as well and nothing. Every time I connect camera it will detect it again and then reboot when it detects disk drive. Also says with the camera that drivers are only required with W98, not XP.

  woodchip 22:39 26 Sep 05

Then that's how it works, If you look in Windows Explorer you will see a Removable Disc at the bottom of the list on the left. That is your camera, the only difference with yours and mine is my computer does not restart after connecting the Cameras

  Bobby237 21:02 29 Sep 05

If I leave my camera connected after it restarts it will redetect it, get to the same point again and then restart again. So every time I have the camera connected it restarts without installing. Hence there is no removable drive in My Computer.

  woodchip 22:39 29 Sep 05

Does it show a Camera Icon as Some does it that way

  woodchip 22:44 29 Sep 05

Try this for your camera. Copy the CD to desktop by right click drag from CD to desktop, choose copy. Now restart your computer in Safe Mode, this you do by keep tapping F5 as the computer starts, if it brings list up choose safe mode. when back into windows in safe mode double click the CD copy on the desktop until you see a Setup file double click this to run setup in safe mode and see if it works that way.

  Bobby237 20:29 26 Oct 05

This hasn't worked either. Could it be an issue with my USB ports/drivers as it doesn't appear to pick up the camera correctly? It shouldn't need the CD for XP. I've also since tried on another PC and the camera is picked up and installed fine and I can then see the images through My Computer.

  woodchip 20:49 26 Oct 05

Have you got SP2 loaded on XP, as that corrects some usb problems. and If this is a old computer running XP that also be the problem

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…