pc refuses to recognise canon camcorder xm2

  junior666 03:35 13 May 07
Locked

Hi, My pc has stopped recognising both of my Canon xm2 camcorders.This is a new problem.Has worked fine for years.But now when I attach my camcorder the machine will totally blank it.I am a wedding Videographer & have came up against a real problem.I cannot load any footage Does this sound familiar to anyone with a solution?
Regards, Junior

  ICF 08:14 13 May 07

Have you tried system restore?

  junior666 14:32 13 May 07

Yes.Tried system restore with no success

  anchor 14:48 13 May 07

If the DVC Storage Driver is already installed, when connecting the camcorder you should be able to 'see' the camcorder as a "Removable Disk" in Windows Explorer.

If nothing happens when you connect your camcorder, check the following items to determine why there is no communication:

Check your PC.
Make sure that your PC has a USB port, and that the operating system is pre-installed Windows 98, Windows 98 SE, Windows Me, Windows 2000, or Windows XP. (If your operating system has been upgraded from an earlier version of Windows, the USB communications may not function properly.)
Check the connection between the camcorder and the PC.
Make sure the USB cable is properly connected at both ends. (Refer to the instruction manual which came with your camcorder.) If the camcorder is connected through a hub, try connecting it directly to the computer. You can also try disconnecting other USB devices (except keyboards or mice), then reconnect the camcorder.
Check your DV camcorder.
Make sure that your camcorder is ready for communication with your PC. The camcorder should be connected to AC power, and set to the Card Play (VCR) mode.

If everything is correct to this point and you still have no communication, Uninstall and Reinstall the DVC Storage Driver.


click here

  junior666 15:14 13 May 07

I am attempting to connect av through the firewire cable.I have replaced the orginal cable with a new one from Canon( in case this was the problem) with no success.However, the pins on the new cable do appear to be in a diferent position from those on the old one.I have been told this is ok, though I'm not so sure this is correct.I will try to uninstall/reinstall the driver to see if this works. Many thanks.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

Where HTML5 is headed next

MacBook Pro v Surface Pro 5