pc is not starting up properly

  JackStanyard 02:09 19 Jun 14
Locked

hi, i recently upgraded my PC with a new motherboard, AMD 6 core CPU, 8GB RAM in a bundle then an nvidia GTX 750 1GB graphics card and a arctic freezer 13 cpu fan seperately. its done with an old 280W PSU (max 450W)

It wouldn't start up so i took it to PC world and they got it to start up but thats all they did, i am getting no display and from what i can see nothing plugged into the USBs at the back is working, no light on the mouse or keyboard etc, even though the hard drive and fans on the graphics card and cpu are working and i can hear the hard drive.

PC world said they don't know what the problem is and i have no idea, so am desperatly trying to find a solution, was wondering if anyone had any ideas?

  wee eddie 08:25 19 Jun 14

Are you sure that the old PSU is sufficiently powerful for that Graphics Card

  Jollyjohn 13:23 19 Jun 14

Definitely power supply related.

Once replaced, use onboard graphics, if available, boot to BIOS and select optimal defaults to start with.

Once working do as suggested re motherboard drivers etc.

Then make sure you have the graphics card drivers and install the graphics card. You may have to change the BIOS setting to use graphics card if you get no display.

  JackStanyard 01:15 20 Jun 14

hi guys, yeah i was thinking about it being the PSU, and i put the motherboard driver in the drive but nothing happened and still couldnt see anything on the screen...dunno if i am doing anything wrong

This thread is now locked and can not be replied to.

Qualcomm Snapdragon 835 benchmarks: Antutu, Geekbench 4, GFXBench and PCMark results

1995-2015: How technology has changed the world in 20 years

This stop-frame animation tells a moving story of domestic violence for Refuge

New iPad 2017 preview: Apple's affordable but underspecced new iPad may appeal to the education…