PC not recognising ethernet connection

  bairn7 09:28 12 Aug 08
Locked

Hi All,

I've been connecting to the internet through a wired router and my ethernet port for the past 6 months without any problem. Last night when I got home my internet was down. I have two computers so I tried the other and it was connecting fine so the service was ok.

When use the faulty computer, the internet light on the modem stops flashing. and the two computer icon in my system tray displays a red cross and says that there is no connection. When I go to 'repair connection' it says that no cable is connected to the ethernet port even though it is!

I haven't installed/updated/removed anything in between the connection working and not working. I am using vista. The only thing that doesn't look right is that when I go into device manager, it shows 'SM Bus Controller' as not installed. Could this be the issue? I can't find my Motherboard install disk to reinstall this though.

I know you'll probably need more info but I'm not that tech savvy so if you let me know what info you need and where to get it, I'll post here.

Thanks for your help
bairn7

  brundle 09:58 12 Aug 08

Check cables & ports first (look inside for damaged pins). Try a different port on the router. Check link lights - they should at least light up when a cable is connected.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…