PC not closing down

  geedad 12:58 PM 19 Mar 12

My HP Pavilion p6530uk, i5 Intel, 4GB Win 7 Home Premium, is not closing down as expected. When I attempt to shut down by clicking 'Shut Down', the PC continues to show "Closing Down" for many minutes and then does not do so, but re-starts!! I have mentioned this on our forum before, and a member suggested that it could be a running program in the background or a device proble. However, I have checked all devices, and they are OK, and I normally have no programs running when I wish to close down. Any clues and solutions, please?


for many minutes

  northumbria61 13:30 PM 19 Mar 12

Try performing a clean boot to determine if it resolves the issue.

Performing a Clean Boot:

Click Start Orb > type msconfig in the searchbox
Click msconfig in the search results
Click the General tab, and click Selective Startup
Under Selective Startup uncheck Load Startup items
Click the Services tab, check the Hide all Microsoft Services box, and then click Disable All
Click OK, and when you are prompted, click Restart.
  northumbria61 13:32 PM 19 Mar 12
  Nontek 13:57 PM 19 Mar 12

Have you checked Power Options to see what your current settings are - might be set to restart, rather than shutdown.

  Nontek 13:59 PM 19 Mar 12

PS, just for info - I have found that on Shutdown, if any programs are still running, Win7 automatically does the business anyway, and within just one or two seconds.

I am also running Win7 with a very similar setup to yourself.

  geedad 14:13 PM 19 Mar 12


Thanks, northumbria61, ,I will try all of the suggestions and links. Will let you know, (eventually!) the result.


Nice to know you have a similar setup, and thanks for the information. As does your PC, when "shutting down", any background software running is closed down prior to shut down - but perhaps not in my case, it seems. However, I will try to follow the advice, ,and let you know how I get on. Thanks a lot.


  geedad 07:19 AM 21 Mar 12


Thank you for your advice.

Tried your advice and links, to no avail. The registery advice from the link indicated that my PC was the same as recommended, and therefore no changes were necessary.

Nontek. Thank you for your response, but again, the settings are as recommended,IE Power Options set to Shut Down.

I thank you both for your responses, and hope that other forum members could pinpoint the problem to stop this annoying nuisance. I have to attempt to shut down the PC a second time when the first shut down fails!

  spuds 09:59 AM 21 Mar 12

How do you 'close' the computer down, or does it eventually close itself down. Because there might be an answer there?.

Not the answer, but I seem to recall having a problem with XP, and it was something to do with 'hibernation'.

  geedad 14:29 PM 21 Mar 12

spuds Sorry for delay.

Power Button.

Do nothing.



Shut down.

That is set to Shut Down.

Sleep Button

Do nothing



That is set to Sleep.

Does that look OK to you? Thanks


  Nontek 16:46 PM 21 Mar 12

I would put Sleep Button at 'Do nothing' .....

  geedad 17:32 PM 21 Mar 12



Will try!



This thread is now locked and can not be replied to.

Best Cyber Monday deals 2015 live blog: Best UK Black Friday weekend deals & best UK Cyber Monday…

1995-2015: How technology has changed the world in 20 years

The best Black Friday Deals for designers and artists – updated

20 Mac Power User Tricks... That You Didn't Know