PC LINE PCL-WS01 optical mouse stopped working

  theDarkness 19:02 03 Oct 10
Locked

Hi, its the cheap £5 optical mouse you usually get with MSI laptops, and Ive been using it on a seperate XP desktop machine for the last day or two. Today, its no longer working on the vista laptop that it was bundled with, there does not seem to be any conflicts within device manager, and when inserting the optial mouse on a 32bit vista system, I do not get any messages or indication that its now connecting to it-for eg its light does not come on. any ideas? thanks

ps the only thing Ive recently installed is think broadbands temp meter, and removing that makes no difference-the system does not recognise that any object has been connected. Ive been googling, and it does not seem likely that Ill get it going again, for eg:- click here

but ill stay optimistic!

  woodchip 19:12 03 Oct 10

Have you tried pressing the button on the usb then quickly Press the one on the bottom of the mouse

  theDarkness 20:57 03 Oct 10

sorry, couldnt get back to the laptop in time. I forgot to mention that whilst it was working on the xp system the other day-it was off and on in controllability on it later during the night. no reinstallation of any drivers seemed to work on vista-perhaps xp damaged it permanently, but its hard to tell for sure.

Sorry-im not sure what you mean by button on the usb,theres no button on the bottom of the mouse, just the infra red, unless u mean the built in mouse pad on the laptop itself-but ive tried just about every combo and nothing seems to work. im not sure what can help solve the issue, if its not just a cheap mouse with a very short lastability, lol. thanks anyway! :)

  theDarkness 00:25 06 Oct 10

Ive tried it again, and the same PC-line mouse is now switching off the vista machine instantly, as soon as I insert the mouse into a usb port! This is definately the oddest thing ive ever encountered. When system and screen goes off completely, and I need to press the on switch to boot up once again.
Its surely not healthy-im assuming its some sort of major conflict? Aside from the pc-line mouse, all I have is the built in mouse on the laptop, a finger pad underneath the keys, but its always worked even when the pc-line usb mouse was connected. Ive never used anything else. Can anyone help me fix this? thanks

  theDarkness 14:36 23 Oct 10

update. I found out it wasnt a conflict, just a mouse with a very bad cable, tugged too hard over time-perhaps from a few yrs of use. Resetting or switching off a laptop is not a nice mouse, lol

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Method Studios' title sequence for BBC series Taboo is truly unsettling

Best Pages for iOS tips | How to use Pages for iPad & iPhone: 7 simple tips to get more out of…