Partitioning gone wrong...

  IMidas 02:05 02 Feb 03
Locked

I’m not really sure what I did in PM, but I wanted to turn my 80Gb HD into two partitions. Originally I told PM to create a second partition (logical partition) of 60gb, leaving the 20gb primary partition. Then because after restarting the partition didn’t appear in ‘my computer’ I did other things, but I can’t remember exactly what. I think I might have turned the logical partition into a primary partition, making two primary partitions or something. Whatever things I did, it went wrong, and I was left with a hard drive that wouldn’t boot. After putting the hard drive onto another computer as a second hard drive, I found that all of the system files were in a folder. I then placed all these files in the root directory (C:), these included windows folder, program files, boot.ini etc. Even after this, when I start the drive up on its own again, it won’t boot up (it gets to the screen after the bios screen and freezes).

Maybe somewhere along the line some important system files have been deleted (all of them appear to be there though – boot.ini, ntldr, ntdetect etc.). Does anyone have any ideas as to what has happened or know some way that all boot info can be put on from scratch?

  oneMegaBit 03:30 02 Feb 03

it seems to me that you have set your second partition to active or boot by mistake.When you do this your computer tries to boot from the empty partition and will either hang after the post or display "invalid system disk or disk error, replace and hit any key when ready" use a startup disk to boot your system (if you don't have one it can be created by using the "create startup disk" feature under windows or going to the command or dos prompt and typing format a: /s on a friends computer) when you have booted with the disk type fdisk and select 'set active partition' under the options then select your primary (c) partition , when this is done. Reboot and your system should now start (as long as you haven't deleted any boot/system files like msdos.sys, io.sys, etc. but these are hidden in the root of your c drive and read only by default so you probably haven't. Oh, and don't forget to format your second partition otherwise windows wont see it.

  IMidas 11:17 02 Feb 03

I've already set the partition active (in partition magic) while I had the hard drive in another computer. Even after this it wouldn't boot, but I sorted it out, because I did 'makeboot' in the recovery console utility. (I must have somewhere along the line deleted some of the system boot files. It boots now, however there are now two options to start up the operating system: both are 'windows default', and when I load up either of them they are exactly the same installation. I've only installed XP once.

How do I get rid of this option every time the computer starts?

  IMidas 17:10 04 Feb 03

I've given up and because of other little problems on the computer - I've formatted it and started from scratch. The partitions are now set up properly.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

15 macOS Sierra tips | How to use macOS Sierra: Secret tricks and best new features in Apple's new…