Packard Bell iXTREME MCE2102 - no power

  Keith4321 12:20 19 Oct 06
Locked

It started with an electrical burning smell, then nothing - no fans, no lights.

Tried a new PSU - same problem, so tried disconnecting different power leads in turn. When 4-pin ATX 12V lead was disconnected, fans worked and power light came on, but nothing else. Same with old PSU, except that PSU fan didn't spin at all, even when CPU fan did.

My guess is that part of motherboard circuitry is burnt out.

Any thoughts...?

  Keith4321 14:52 19 Oct 06

Just trying to get back to top of pile...! Can anybody help?

  Keith4321 16:53 21 Oct 06

trying again...

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Here's what should be coming to Adobe Project Felix in 2017

Apple AirPods review: Apple's beautiful new Bluetooth headphones bring true intelligence to…