Packard Bell argo c bios setup problem

  zaphyr 00:05 12 Jan 11

I own a packard bell argo c laptop. It was working fine till a couple of weeks ago. It seems that my harddrive (40G) is failing and I decided to buy one with a higher storage capacity. Normally it would be an easy thing to do. Tried to install Vista but it seems my bios doesnt support (no drivers) for that new harddrive. I tried to flash the bios, with the flash tool from Packard bells website. But it doesnt seem to work. It seems that the bios is Fix to its old settings and cant be changed. I also tried to upgrade its memory from 1 Gig to 2 Gig (2x1Gig modules) but it doesnt allow this aswell. So thats my problems. Need Help...

  lotvic 01:01 12 Jan 11

Can you be clearer in your explanations please.
It's very vague, with all the 'seems' - what exactly happens?
Also how can it 'not allow' you to put the extra memory in?

In the mean time you could read through the install guides at click here for installing on a new HDD

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

Where HTML5 is headed next

MacBook Pro v Surface Pro 5