Outlook VBA program not firing when new E:Mail

  Heefie 11:12 13 Oct 09
Locked

I've just rebuilt my windows Vista system, due to numerous space & performance problems. This is not normally a problem, as the only thing that I have on my C: drive is Windows, everything else is on other drives, it's just a matter of doing a few updates & re-installs to rebuild the Registry.

Therefore, having re-installed Office 2003, I've got my Macros back in place and they all run if I invoke them, but the main one, which used to trigger every time I got a new E:Mail is not firing automatically ... I am assuming I've forgotten to do something, or I've done something wrong ... please help !!!

I have the following code in a ClassModule, ThisOutlookSession1, but it doesn't fire :

Sub Application_NewMailEx(ByVal EntryIDCollection As String)

Call MyRules
Call ValidateKATurns
Call KATurns

End Sub

have no idea if this is relevant, but under the Properties for ThisOutlookSession1 is a single entry, Instancing, with the value 2 - PublicNotCreatable

Also, just as background ... when I open VBA, the tree on the left hand side of the screen says :

Project1(VbaProject.OTM)
Microsoft Office Outlook Objects
ThisOutlookSession (this Is empty)
Forms
KA_Files_Received
Modules
Definitions
KA_Turns
My_Rules
Validate_KA_Turns
Class Modules
ThisOutlookSession1 (this contains the aforementioned code)

Thanks in advance for any help ...

BTW, a formatted version of this question, if this is unreadable, can be found here : click here

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now