Optical drives can't read from cd or dvd

  reddwarf 19:40 21 Sep 04
Locked

I am trying to sort out a computer for a friend and have run into something I can't fathom. The optical drives will recognise that a disk has been put into the drive but when you try to read from it you get the no disk in the drive message.

I fixed this by running system restore and thought the problem had gone, but after about 5-6 uses both the drives fail to operate properly.

System restore will put it right again but running it should not be needed just to keep these drives in operation.

Packard Bell iMedia system running Win XP Home 256MB ram P4 2.6GHz DVD drive CDRW drive.

The drives are found in the Bios and shown as working properly in device manager

  reddwarf 09:30 22 Sep 04

bump

  jack 10:37 22 Sep 04

How about going from scratch?
Disconnect power and data cable -both ends.
Remove all related software, driver, burner, etc.

Power down

Reconnect.
Start up
Install driver
Install software one at a time and then test each item before the next.
If any soft ware is pre XP- check compatability.
See what happens

  jack 10:49 22 Sep 04

Also check the master slave relationship/on each ISA bus Ie if they are to gether on the same bus
one [prefably the fastest] should be master the other a slave.
If they are on different ISA bus with other drives. one must be master the other slave.
Hardrives should be master and subsidury drives
[optical/zip] slaves.

  reddwarf 05:25 23 Sep 04

Still no joy I'm afraid.

I feel it has to be software rather than a hardware fault as system restore fixes it every time. Antivirus and Firewall installed and upto date.

Any more thoughts anyone?

  reddwarf 07:48 05 Oct 04

bump

  Diodorus Siculus 08:04 05 Oct 04

HAve you tried the system file checker

start

run

sfc /scannow

It needs the OS CD.

[This is my usual recommendation for software faults but I am not sure of its value this time...]

  reddwarf 21:08 21 Mar 05

A long time ago I know but the answer may help somebody. The problem was caused by security software supplied with a pendrive. When the software was installed the optical drives weren't seen. Take the software away and back came the drives. It seems this problem was quite widespread around the workplace where this pendrives had been issued.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…