Open with Photoshop CS2

  Farleyjim 13:20 27 Nov 06
Locked

I've just installed Photoshop CS2 (which replaces Photoshop 7). My problem is that I cannot open my pictures with CS2 by double clicking on a file. When I first installed it, I still had Photoshop 7 on my machine and the pictures opened with that. However, when I right click a picture and click "open with........" it opened with 7, and CS2 did not appear in the available programs to "open with", so I uninstalled Photoshop 7 to avoid any conflict but CS2 still doesn't appear in the list and I don't know how to put it there. Any ideas please?

  jimv7 13:55 27 Nov 06

Right click a file, open with, browse to photoshop cs2, click ok.

  hssutton 14:28 27 Nov 06

You may need to a little further than the above post.

PS CS2 may not show in the "Open With" box (often the case). If this is the case hit the browse button at the bottom of the Open With box. Look in Program Files>>Adobe>> look for Adobe Photoshop CS2, click on this, then on Photoshop.exe. This will now include PS CS2 in the Open With box.

  Farleyjim 14:52 27 Nov 06

Thanks jimv7 and hssutton. That's the problem, I've done that before and it still doesn't appear in the "open with" box. Windows picture and fax viewer is the only one that is highlighted.

  Farleyjim 17:26 27 Nov 06

Just to clarify: when I press "Browse" and get to "photoshop.exe" and press the "open" button, it goes straight back to the "open with" dialogue box with "Windows picture and fax viewer" highlighted but there is no Photoshop CS2 to be seen!!

  hssutton 18:20 27 Nov 06

This is a known problem with later versions of PS, and can be cured, but means editing the registry, so beware.

HKEY_CLASSES_ROOTApplicationsPhotoshop.exeshellopencommand(Default)

For some reason, sometimes Windows XP creates this key the first time without "%1" at the end. Delete the (Default) entry.

Go to Windows Explorer, select a file type you want to open in Photoshop, right click, go to Open With, select Choose Program, click Browse (Photoshop won't be in the list after deleting the registry key), select your Photoshop executable, and make sure "Always use..." is checked.

  Farleyjim 08:12 28 Nov 06

Thanks hssutton. I've looked in the registry where you suggested and am dismayed to find the line"C\Program Files\Adobe\Photoshop 7.0\photoshop.exe" "%1"(it does have "%1") I'm a bit scared to do anything at this stage without further advice...there is still reference to Photoshop 7.0 which(I thought) I had uninstalled. I have done a registry scan with Norton Utilities but despite it showing a few faults and fixing them, the problem still remains. If I deleted that line, would I not get other problems?

  iambeavis 10:34 28 Nov 06

Navigate to the registry entry, given by hssutton. In the right-hand pane, right-click on default - choose modify and, in the pop-up box, change Photoshop 7.0 to Photoshop CS2.

  hssutton 11:10 28 Nov 06

As iambeavis says, or just deleting it then going through the "open with procedure".

Have been searching the Adobe site for you.

This is what Adobe says.

Q. When I double click some image files in Explorer, or select Open With, Photoshop starts but instead of loading the file presents a New Image d/box.

A. XP/Win2k has put in a bad registry key used for opening that kind of file. If you feel *comfortable* editing the registry, you can find the bad key at

HKEY_CLASSES_ROOT\Applications\Photoshop.exe\shell\open\command\(Default)

For some reason, sometimes Windows XP creates this key the first time without "%1" at the end. Delete the (Default) entry, go to Windows Explorer, select a file type you want to open in Photoshop, right click, go to Open With, select Choose Program, click Browse (Photoshop won't be in the list after deleting the registry key), select your Photoshop executable, and make sure "Always use..." is checked.

If you do not feel comfortable editing the registry DO NOT DO THIS.

You can work around it by dragging the image onto the Photoshop main window background after Photoshop is opened.

click here
However you may need to register to access the forum.

I had the same problem when I installed CS2, following the prescribed procedure worked ok for me, but must admit to a little trepidation when I did it

  Farleyjim 15:25 28 Nov 06

I changed the entry from Photoshop 7.0 to Photoshop CS2 and that seems to have done nothing. I rebooted to see if that made any difference but nothing. Given that I am very scared to delete anything in the registry perhaps you would be patient enough to tell me exactly what I delete. Is it everything in the right hand pane or just the Photoshop.exe in the left hand pane?
Is there any merit in uninstalling and re installing CS2?

  iambeavis 16:15 28 Nov 06

The entry to delete is the 'default' entry (in the right-hand pane), on which you right-clicked to modify the previous entry. This time, rather than choosing 'modify' choose 'delete', but take note of hssuttons post - "If you do not feel comfortable editing the registry DO NOT DO THIS.".

If you just wish to view the image files, it's best to use 'Windows Picture and Fax Viewer' as it's much faster and, if you wish to edit the files, it's better to open them directly from 'Photoshop' using the file > open >navigate to your image file option

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…