Office 2003 registry problem

Hello there,

I seem to have inherited a problem with Office 2003 that i cannot find a solution or work around too.

I am trying to install Office 2k3 SP3 and other office updates but they cannot be applied as there are registry keys that cannot be accessed.

When i try to apply SP3 i am greeted with the error:

Cannot access UNKNOWN\.frg\Access.Fragment\ShellNew
Please check you have sufficienet permissions etc

When i try to detect and repair Office i am greeted with the same error

When i try to re-install office or uninstall office, also modify it i am greeted with the same error but on the following key:

HKLM\software\classes\CLSID\{CC2C83A6-9BE4-11D0-98E7-00C04FC2CAF5}\SingleChangeHook

When i navigate to these keys manually i get an access is denied error message.

I have tried system restore, my earliest avail date is Oct 4th and this does not resolve the problem.

I have tried all of the above using various accounts: local admin, domain admin, domain user (who is member of local admins), and a local user.
All to no avail, same outcome with all users.

So i cannot update Office, cannot uninstall it, cannot re-install it, cannot run detect and repair on it.

Running Vista Buisiness, fully patched up to date. (apart from Office)

Does anyone have any suggestions on how i can further proceed with this issue?

Thanks

  rawprawn 14:36 23 Oct 07

Try turning User Account Control Off.(Control Panel>User Accounts)

its already off rawprawn, was the very first thing i did when i installed Vista.

This is my first major problem with Vista in just under a year so i cant grumble too much.

Just absolutly gazumped on what possibly i can try next.

  mole44 17:17 23 Oct 07

have you tries uninstalling office then running ccleaner and reinstalling everything again.

  VoG II 17:44 23 Oct 07

Try running the Windows Installer Cleanup Utility click here then re-install Office.

  FreeCell 18:12 23 Oct 07

With Office 2000 install on Vista there were similarly some updates that would not load. Found a solution was to download the update as Saved file to hard drive and then run from there in XP compatibility mode using mouse right-click on downloaded file.

  Edgar508 09:10 24 Oct 07

I am struggling with same.
VoG, already tried Win Installer Cleanup Util and still get error on re-install (UNKNOWN\.frg\Access.Fragment\ShellNew)

Also tried changing permissions in the Registry for access.fragment but it won't allow me to open the file

more ideas?

mole44 - thanks for your input but as stated above i cannot uninstall Office as i get the secong registry key error.

VoG - will try now thanks

FreeCell - does not work unfortunatley

Edgar508 - glad im not the only 1 with this problem.

Tried the installer cleanup, rebooted machine, ran regseeker and i still cannot remove the .frg registry class key!!

So still cannot get past the Office errors!

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Method Studios' title sequence for BBC series Taboo is truly unsettling

Best Pages for iOS tips | How to use Pages for iPad & iPhone: 6 simple tips to get more out of…