ntldr is missing- adding new hard drive.

  gillaroo 21:02 15 Aug 03
Locked

I recently built a new computer with a clean install of XP home. Previous comp had two identical drives, one with OS and progs, and the other stored my docs with thousands of photos.I formatted my old c drive and installed XP on that. Installed the progs I wanted and all is working fine.
When I connect the old drive with the photos I get "NTLDR is missing"
If I disconnect the "photo" drive all works fine again.

I DO have the pics backed up, but IF there is a way to just connect the drive in without formatting and losing them all, I would be very grateful if some kind soul were to tell me how!
Thanks for any help you may be able to give,
Colin

  gillaroo 21:13 15 Aug 03

I should say post and BIOS recognise the second photo drive correctly....

  sil_ver 21:15 15 Aug 03

Have you got the photo HDD jumper set as slave?

  gillaroo 21:18 15 Aug 03

Yes, jumper is at slave. I didnt change jumpers- Previous set up had old/new c drive as master, as it is now, and the "old" photo drive as slave- exactly what I'm trying to achieve now.

  sil_ver 22:01 15 Aug 03

I can't even guess at an answer to your problem but this site may give you something to ponder on even tho' it refers to dual boot systems click here

  temp003 05:43 16 Aug 03

Somehow (don't really know why), when your 2nd hdd is connected, XP is confused and is possibly looking for the boot files (ntldr being one of them) in the wrong place. It is strange because from the sound of things, the 2nd hdd was never made a boot disk even in your previous set-up.

Try fixing the MBR of the 2nd hdd. It would not (at least should not) cause you any grief. Glad to hear you have another backup copy of the photos anyway.

Connect the 2nd hard disk as slave, and make sure jumper settings are correct. Go into BIOS to make sure that it's detected (I'm sure you've done this already). Also check the boot sequence in BIOS. At this stage, make your CD ROM your first boot device, then your master hdd the second.

Restart computer with XP Home CD inserted. When XP Setup welcome screen appears, press R to go into Recovery Console. It should then list your XP installation as "1. C:\WINDOWS".

Press 1 and press Enter. Then enter your administrator password.

At the C:\WINDOWS> prompt, type map and press enter.

You'll see your partitions listed, and the device names (names of your hard disks).

Your 2nd hard disk should be called:

"\device\harddisk1"

and the photos partition (assuming there's only one or at least the first partition on that disk) should be called \device\harddisk1\partition1.

Check the partition drive letter, device name and partitition size in MB to make sure that you are looking at the right disk.

When satisfied that \device\harddisk1 is really your 2nd hdd, at the C:\WINDOWS> prompt, type:

"fixmbr \device\harddisk1"

without the quotation marks and note that there is one space after fixmbr. You'll be warned about changing the MBR of a device, but confirm that it's what you want to do.

After that, at the same prompt, type exit and press enter. Computer will restart. Remove XP CD and see if the computer will get into XP.

If you still get an error message about missing ntldr or some other file, restart computer with XP CD again. Go into Recovery Console again as before, and at the prompt, type:

"fixmbr \device\harddisk0" without the quotation marks and press enter. Confirm the action.

Then at the prompt, type:

"bootcfg /rebuild"

and press enter, without the quotation marks and note the slash (or whatever it's called) this time is different. This command will rewrite the boot.ini file and hopefully write the correct boot path for XP.

Recovery Console will scan your disks for XP installations and list them out. There is only one, which should be C:\WINDOWS

When asked whether to add it to the boot list, say yes.

When asked to enter the Load Identifier, type:

Windows XP Home

and press enter.

When asked for the operating system load option, type:

/fastdetect

and press enter.

This should complete rewriting boot.ini.

Back at the prompt, type exit and restart. Remove CD and pray that it works.

  temp003 05:47 16 Aug 03

Just to make it clear, if you do need to use the bootcfg command, there's a space after bootcfg.

  Wes Tam ;-) 06:08 16 Aug 03

gillaroo maybe this will help from click here

  gillaroo 11:15 16 Aug 03

Temp , thanks- , everything is now sorted. I am embarassed to admit that only the first paragraph of your reply was necessary. Your point re XP looking in the wrong place for the boot files, and instruction to change the boot order in bios solved it. Although bios and post recognised both drives, when I went to change boot order in bios I found that the hdd setting had been set to HDD1, and not HDD0 as it should have been. This appears to make no difference when only one drive is fitted, but of course when the second was connected, XP was looking on the wrong drive.
Thanks again, and apologies for wasting your time.
Colin

  temp003 05:18 17 Aug 03

Funny that, because I was going to skip the first 3 paragraphs, thinking that it might smack too much of musing on my part. It didn't really occur to me that your computer was booting up from the wrong hdd. With hindsight, it was pretty obvious :o))

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…