"not a valid Win32 application" - 4OD Install

  OK Computer 20:10 23 Oct 07
Locked

Hi,

I'm trying to install Channel 4 On Demand. Well, to be honest, I already had it installed but the glorious techies at Channel 4 demanded I upgrade.

When I try to download or simply run the update I get the following error message:

C:\channel4_on_demand.exe is not a valid Win32 application

I've tried uninstalling 4OD completely and installing it from fresh but I directs me to the same file and ultimately the same error.

I've uninstalled and re-installed Adobe Flash Player but had no joy.

Basically I just wanna know whether it's a problem with my laptop (XP Home 32 bit) or the download from C4.

It can be downloaded and run from here (it's like 3MB so must install directly from the website)

click here

  brundle 22:14 23 Oct 07

I downloaded and used it only last night, worked fine. Try downloading with a download manager - I realise that's just installing a bit of software in order to get another bit of software, but worth a try.click here

  Fruit Bat /\0/\ 23:00 23 Oct 07

Not a valid win32 Application click here

  OK Computer 08:12 24 Oct 07

Thanks for the replies. I managed to solve this late last night by clearing my browser cache and cookies.

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…