nobeep no p.o.s.t no boot up

I have just put together a pc an ecs kv2 motherboard cheaked and re cheaked all the conections how ever when i switch on board lights up but no beeps at all and no post and no vision from the vga card have changed the card to one i know works have swapped the memory unplugged everything except the HD and graphics card changed the power to a more powerful one still nothing no post no vision there is no troublshooter on the ecs site so i am lost is this really a busted motherboard any ideas of things that i could try ?

  BurrWalnut 19:23 29 May 05

Unplug everything from the motherboard except the CPU with its heatsink and fan, power supply, power switch and case speaker. Switch on and you should get a BIOS beep indicating that there is a problem (no memory or monitor/graphics card). This won't be the short single beep that indicates that everything is OK, but a long beep or series of beeps indicating a problem. If you do get a beep signal, refit the components starting with the monitor and memory until you fail to get the beep. You will then know what is causing the failure.

If you get no beeps the mobo is suspect.

ok thanks for that it now seems that any card put in to the PCI slot results in a loss of a post beep i have three different graphics cards and as far as i know they all work one is even an AGP card how ever as soon as i put any of them in to any of the slots the post beep is lost does that mean the PCI slots on the mobo are dead ? each slot has a blue led next to it and they all seem to light up flash when nothing is in the slot solid when something is in the slot are they there to help or just to look good?

  Night Ryder 20:51 29 May 05

There are two groups of graphics cards which expect different voltages from the motherboard. If you have an old graphics card you will have to check the specification of your motherboard and graphics card to make sure they match.

  Night Ryder 20:52 29 May 05

PS, you may also have to change BIOS settings. Check motherboard manual.

  Night Ryder 20:54 29 May 05

Be aware that this kind of mis match can cause damage to motherboard or graphics card or both.

  woodchip 21:45 29 May 05

It may be the PSU not pumping enough power out

i can't change the bios if i can't see the screen can i? and i now have a 4oow psu in there that should be enough ? as i only have a hard drive and a graphics card plugged in. the manual does not say anything about pci voltages it does say that you can change lots with the support cd but as i can't see it how do i use it ?
just went out and bought a agp graphics card today and that doen't work
any other ideas ? (i just do not want to believe that my mobo is dead the hassel is imeasureable as i no longer can find the recipt nuts!

  woodchip 23:11 29 May 05

Try the Board out of the case on a piece of card, Just with Graphics CPU and one stick memory. To see if you can get it to post, if it does you can get to BIOS if screen lights up

  DieSse 23:14 29 May 05

I would strogly suspect the motherboard from waht you have done so far.

But, you could try - take the m/b out of the case - lat it on something non-conductive (I usually use a sheet of cardboard) - connect the bits up again and try it. This removes the possibility that something's shorting out to the case - often a mounting post where there shouldn't be one.

  DieSse 23:14 29 May 05

snap!

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

15 macOS Sierra tips | How to use macOS Sierra: Secret tricks and best new features in Apple's new…