No wireless after fresh install of XP

  BeeWee 08:53 21 Jun 10
Locked

I have a Sony Vaio VGN S3HP laptop. I have done a fresh install of Windows XP. I now have more problems than I started with!

In device manager the following are yellow:
Ethernet Controller
Mass Storage Controller
Modem Dev on HD Audio Bus
UGX
Video controller VGA compatible
Network Controller

I don't understand it.

I can't pick up wireless internet and have a small display only in the middle of the screen with a wide black margin all around.

Please can anyone advise? I bought the laptop about 4 years ago without any recovery discs.

  onthelimit 09:01 21 Jun 10

There is a problem with those drivers. If you can get on line with a cable, download the latest versions of each of them from the manufacturers websites. If you can't you will need to use another computer and put them on a flash drive.

  onthelimit 09:11 21 Jun 10

Another thought - does your XP CD include SP 3? There may be later drivers on there. If not, download and install it (you're better off having it even if it doesn't cure this particular problem).

  BeeWee 09:18 21 Jun 10

Thank you for your prompt reply onthelimit. I do have the use of another computer running Windows 7.
I don't know where to go to get the latest versions of those drivers..I don't even know what they drive! Do they make the internet work?

The XP CD doesn't have SP 3 on it so should I d/l on to a CD and then put it in the laptop?

You might have guessed that I'm not too good at this stuff and I have been trying for 3 days to work it out.

  onthelimit 10:08 21 Jun 10

Have you tired connecting with a cable (if you have one) yet? It may not work as the ethernet controller is your internet connection - however, I have had wireless controllers that have shown up in device manager as ethernet controllers! So, worth a try. If not, you could download SP 3 and then install it. It can take several hours to do and, towrds the end, you may think it's stuck on 'cleaning up files'. As far as the drivers are concerned, if you can connect to the internet, run the Belarc scanner click here. This will give you details of all the hardware on your laptop. It's then (relatively) straightforward to google the maker , go to the site and find the drivers for your particular piece of kit.

  onthelimit 10:09 21 Jun 10

Should have said 'from another PC, burn to disc and install on your laptop'.

  onthelimit 10:21 21 Jun 10

Another thing to try, in case there was a glitch during the XP install, is to uninstall on of the drivers that have the yellow exclamation mark (right click the device and click uninstall), then reboot the computer and see if XP installs the driver. If it does, then do the same thing for each of the others.

  Ian in Northampton 11:09 21 Jun 10

Reading between the lines of what BeeWee has posted, we may need to step back a little here. My sense is that BeeWee is unsure about the function of drivers, so a brief tutorial may be necessary.

BeeWee: when you install XP, it is 'generic' - i.e. it can be installed on any PC/laptop, regardless of configuration. It also installs many commonly-found drivers - but rarely installs all the drivers needed by any individual machine.

So what is a driver? A driver is a program that tells XP how to interact with some of the hardware that's part of your computer. Every hardware device needs a driver - sound, graphics, Ethernet, wireless and so on.

Generally, you would get drivers for your machine as part of a recovery CD - but, as you say, you didn't. What this means is that you need to go to a manufacturer's web site in order to obtain those drivers.

What you describe is a classic case of a clean XP install where the drivers have not yet been installed - that's what the yellow exclamation marks in Device Manager mean. And yes, the lack of drivers would certainly give the symptoms you require - e.g. no wireless.

So: in your case, you probably need to head to the Sony site armed with your model number and see what you can find. Once you think you’ve found what you’re looking for, come back for help in how to actually install them.

Sorry, by the way, if I’ve underestimated your knowledge/competence…

  BeeWee 11:10 21 Jun 10

No haven't got a cable and I can't connect to the internet with the laptop. So what I'll do is to d/l SP3 from the PC on to a cd and run that in the laptop. Will I need SP 2 first as I don't think that is on the xp cd either (the one I used for the fresh install)

I did uninstall all the drivers with a yellow ! after them but it was of no use after a reboot as it was just the same.

thank you for your time

  tullie 11:24 21 Jun 10

If you havent got a cable,hows the pc connected?

  tullie 11:25 21 Jun 10

If you havent got a cable,hows the pc connected?

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

How Nearly Normal created super-fun papercraft for Google

47 iPhone camera tips to help you take better photos