No Power on Avent 8117

  mcheathen 14:32 PM 31 May 12
Locked

The laptop can't get powered up. Even when fully charged when power switch is pressed the green light appears for a split second and disappears. The same thing happens if using pwer direct from AC mains source.

Maybe the battery is faulty as there appears to be no warmth coming off it. Or maybe the pwer switch. Any suggestions?

  Fruit Bat /\0/\ 16:00 PM 31 May 12

Tried with battery removed and on mains only?

  mcheathen 16:54 PM 31 May 12

Yes its been tried with battery removed and wired to mains supply. Still nothing.

  Fruit Bat /\0/\ 17:11 PM 31 May 12
  1. Turn off the computer,
  2. Take the battery out
  3. Take out the power supply
  4. Push the power button down and hold for 30 seconds.
  5. Reconnect power supply
  6. Then the battery.
  7. Retry to boot

Hopefully this will rid the Mboard of static

  mcheathen 02:14 AM 08 Jun 12

I tried Fruit Bat's advice, but still no joy. I even took the battery out and tried to power up directly from the mains supply. Still no joy.

Am I correct in assuming that the battery is part of the circuit? thus explaining why it couldn't get powered up via mains supply?

I checked the power cable with a volt meter and I got a reading of the expected voltage. So am I correct in assuming that the battery must be at fault?

  tullie 04:20 AM 08 Jun 12

The laptop should start with,or without the battery

  Fruit Bat /\0/\ 17:14 PM 08 Jun 12

remove memory cards retry if boots to error message or beeps then a faulty card is causing the problem.

remove wireless card and retry

remove DVD retry

remove HDD as above.

if same on all of above then its looking like a faulty motherboard

Advertisement

This thread is now locked and can not be replied to.

How to watch iPhone 6s, iPhone 6s Plus launch live: What to expect from Apple's 9 September 2015…

1995-2015: How technology has changed the world in 20 years

This installation lets you control a laser and sound show using your mind

Apple's special event invitations decoded: A look back at 13 of Apple's most cryptic invites