No Life at all in Computer! Please Help!

A friend has asked me to set up a wireless network for him.

When I went to install the wireless network card in the computer, I installed the driver off the CD first then opened the computer and installed the wireless network card.

I plugged all the cables back in and attempted to start the computer. However, nothing at all happened when pressing the power button - no fans or beeps - Nothing.

I have removed the card and tried powering it up again and still nothing happens!

When plugging the cable back in, the CPU fan spins once and that is the most I can get out of it.

I have checked that the power switch on the PSU is switched on.

What else can I do?

The computer is a Packard Bell PB 1050
The motherboard is listed as 'Florida' but looking at the motherboard, all I can find is N1996 and MS-6340

Thanks in advance for all help received

Dave

  TOPCAT® 21:32 09 May 05

Check the connection from the PSU to motherboard - could be it was disturbed and isn't fully seated. TC.

Checked that, still no life.

Dave

  vandango 21:38 09 May 05

Could be a faulty psu, i've had this problem before. try using an alternative if possible.

i will try that on my other pc.

  lotvic 22:33 09 May 05

try checking the power switch on front of pc - it may not be making contact

  DieSse 22:54 09 May 05

When you installed the card, did you remove mains power from the system?

If you only switched off in the normal way, there is still power to the motherboard, and if you change components you may damage the component and the motherboard.

and I can't believe what it was...lotvic, it was what you said.

The side panel that has to be removed is on the opposite side to that of my computer which made me take the wrong side off at first. When I put it back, it hadn't slotted into the front panel correctly. This must have caused a problem with the power switch as when I did slot it in correctly, I could tell that there was a difference by the feel of the power switch. The computer booted up fine and now the wireless network is up and running :o)

It's amazing how easy you can overlook the basic things and start trying all the technical stuff - I had allready before that started removing things like the graphics card and RAM to see if they were the cause incase I had zapped any with static that may have built up inside me as the computer was in the attic so there was nowhere I could earth myself.

Thanks for all the replies

Dave

  Switcher 23:25 09 May 05

I had the same problem with a Packard Bell. It tirned out to be the power switch on the front, the micro switch had popped out of its mounting, due to someone with a heavy finger. If it is difficult to get to, trace the connector to the motherboard, lift it of and short the two pins on the motherboard momentarily if it then powers up the problem lies with the switch.

you got the problem exactly right.

Must be a common thing to happen with the old Packard Bell cases.

This thread is now locked and can not be replied to.

Intel Coffee Lake 8th-gen Core processors release date rumours

1995-2015: How technology has changed the world in 20 years

Framestore’s haunting post-WWII title sequence for new BBC series SS-GB

How to install MacOS Sierra on an older Mac: Get Sierra running on Macs & MacBooks from before 2009