No laptop connection after reinstall

  Ollyolly 12:57 03 Mar 08
Locked

My son decided to reformat his laptop hard drive and reinstall Win XP.
XP boots perfectly but he cannot connect to our family wireless router.
A switch on the laptop used to light up on and gain connection automatically. This no longer happens.
We've checked the BIOS and it reads along the lines of Onboard LAN enabled.
We've checked device manager and that doesn't indicate any problems.
I'm guessing that everything is working but we need to enable something somewhere where we haven't looked yet.
Does anybody have any ideas?
Thanks

  Fingees 14:04 03 Mar 08

Make and model of laptop?

Some have a switch on right front just below keyboard to activate wireless.mode.

Just a thought.

  tullie 14:32 03 Mar 08

And have you initially set it up using our Ethernet cable?

  Ollyolly 15:21 03 Mar 08

Fingees,
Thanks for your response.
Laptop is manufactured by HP, I don't know the exact model number as it isn't with me at the moment.
The switch you refer to in this case is between the keyboard and the screen hinge and is the switch I mentioned in my posting. It is currently unlit and however my son presses it (short or long presses) it won't light.

  Ollyolly 15:35 03 Mar 08

Tullie,
Thanks for your thoughts.
The laptop has not been set up with an ethernet cable this time or ever in the past.
When I first bought the router my son already had his laptop. When the router was set up the laptop found it automatically, it was just a case of us entering the necessary password.

  keef66 17:03 03 Mar 08

if he has formatted the hdd then he probably needs to reinstall the motherboard chipset drivers either from a cd supplied with the laptop, of from HP's website. Clearly if the latter you'll have to use another pc to get them!

  Ollyolly 19:31 06 Mar 08

keef66
Thanks for your advice.
After some searching my son managed to find some CDs which came with his laptop. As you can imagine he hadn't installed them. They contained drivers for the graphics card, sound and modem to name just a few.
I've installed the lot and the laptop connected to the internet via the family router at the first request.
He now has sound which he tells me he didn't have either.
Problem seems to be solved, son is very happy, thanks again.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Method Studios' title sequence for BBC series Taboo is truly unsettling

Best Pages for iOS tips | How to use Pages for iPad & iPhone: 7 simple tips to get more out of…