no internet gateway found

  lonemascot 12:40 11 Dec 05
Locked

i have:
a wireless connection between my laptop and PC.
A BT voyager 205 ADSL router connected to the PC via ethernet cable.
5 users set up on the PC. two of which cannot access the internet for some reason. the other 3 have no problems.

my laptop can access the internet if it is directly connected to the modem but it cant connect through the wireless network. It used to do it just fine.

everything is switched on and connected but i get a message on my laptop saying that there is no gateway found.

please help me

  woodchip 14:10 11 Dec 05

Check the settings have not changed in the laptop these should be as the router settings then save and shut router modem off, then restart it after about five minutes

  lonemascot 15:02 11 Dec 05

got no idea where to look for the settings. i did check the network connection setting of the wireless and LAN network but they seemed ok.

  ade.h 15:04 11 Dec 05

Run ipconfig /all from a command prompt on both PCs and compare the details.

  lonemascot 15:21 11 Dec 05

do i do that by typing ipconfig /all in the 'run' option in the start menu? sorry i'm not all that with PC's

  lonemascot 15:25 11 Dec 05

don't worry i worked it out, but i don't really understand wot im looking at here

  lonemascot 15:31 11 Dec 05

the (wireless network connection) auto configuration ip address is different.
Ip routing is yes on PC and no on lappy.
Node type is unknown on PC and mixed on lappy.
both got no to wins proxy enabled.

  lonemascot 16:30 11 Dec 05

I still need help please

  mgmcc 17:31 11 Dec 05

If I understand correctly, you have a Desktop PC connected to a router and have set up a separate "Ad Hoc" wireless network between the PC and laptop with Internet Connection Sharing enabled in the PC.

That being the case, when you run IPCONFIG /ALL, the laptop should have an address in the 192.168.0.x range, allocated by DHCP. The Default Gateway, DHCP Server and DNS Server addresses should all be 192.168.0.1 which is (or should be!) the IP address of the Wireless Network Adapter in the desktop PC.

You need to check that Internet Connection Sharing is set up properly in the Desktop PC and that the address 192.168.0.1 has been allocated to its Wireless Network Connection and not the Local Area Connection (if it also has a free "wired" ethernet card installed). If the wrong adapter has been configured, remove Internet Connection Sharing from the actual internet connection (the modem connection), disable the Local Area Connection and then set up Internet Connection Sharing again on the modem connection. The WiFi adapter should now have been "Manually configured" with the fixed IP address 192.168.0.1 and subnet mask 255.255.255.0

The laptop's Wireless Network connection remains set to get its IP and DNS addresses automatcally.

Ensure any firewall software is configured to allow access to the networked computers in its "trusted" area.

  lonemascot 21:18 11 Dec 05

I am connected via ad hoc. This is what I found after running IPCONFIG /ALL on both computers:

Desktop PC Windows IP Configuration

Wireless Network:

Dhcp Enabled. . . . . . . : No
IP Address. . . . . . . . : 192.168.0.1
Subnet Mask . . . . . . . : 255.255.255.0
Default Gateway . . . . . : 192.168.0.1
DNS Servers . . . . . . . : 192.168.0.1

PC to Router modem:

Dhcp Enabled. . . . . . . : Yes
Autoconfiguration Enabled : Yes
IP Address. . . . . . . . : 192.168.1.3
Subnet Mask . . . . . . . : 255.255.255.0
Default Gateway . . . . . : 192.168.1.1
DHCP Server . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . : 192.168.1.1

Laptop IP Configuration

Wireless Network:

Dhcp Enabled. . . . . : Yes
IP Address. . . . . . : 169.254.184.186
Subnet Mask . . . . . : 255.255.0.0
Default Gateway . . . :
DNS Servers . . . . . : not even listed

PC to Router modem: Just says it is disconnected

I understand that some of these addresses are wrong. How do i change them? I tried following the above instructions but the DHCP address was still different and i couldn't seem to get the laptop's IP to be in the 192.168.0.x range. Please help as im pulling my hair out over this.

  woodchip 21:24 11 Dec 05

Go to My Computer On all Computers Networking Then Check TCP\IP is set DNS Automatic

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…