No Drive Letter for Slave in XP

  griffo 14:59 25 Jun 05
Locked

I have installed a new HDD and installed XP Pro, moving the previous Master HD into a removable caddy, set as Slave. I was hoping that on startup I would be offered the choice between booting in W98SE (Slave) or XP but no! The slave hasn't been allocated a drive letter in XP, although it shows in Disk Management. I have seen in earlier posts that this may be because there is no partition on this drive but I can't create one as there is no visible free(unallocated) space and 'change drive letter' is greyed out. Can anyone help please?

  rawprawn 15:04 25 Jun 05

Have you formatted it in disc management? if not do so.

  griffo 15:08 25 Jun 05

don't want to do that, all my existing data/programs are on that drive. I was hoping this method would allow me to upgrade to XP, giving me time to transfer all my 'stuff', having a dual-boot system meantime, then ultimately, reformat the 'old' drive and use for back-ups.

  rawprawn 15:09 25 Jun 05

Sorry I didn't read it properly, but I don't know about being offered a choice of booting between the two HDD, I would ignore my previous post.

  griffo 15:12 25 Jun 05

no problem, appreciate you trying to help.

  LastChip 15:15 25 Jun 05

This leads to yet more questions.

Did you have the caddy connected and set to slave at the time you installed XP?

How is the caddy connected to the computer?

  griffo 15:23 25 Jun 05

Yes the caddy was being used with a 6.8GB disc as a slave and worked fine. Ive just taken the 'resident' HD (W98), set the jumper to slave (it lists as that during booting),and put it in the caddy, then set the jumper to master on the new HD and fitted it in place of the 'old resident' HD. The caddy is on the second connector at the end of the IDE cable, with the master on the first connector, as it was before.
Hope that makes sense?

  LastChip 15:37 25 Jun 05

I'll rephrase my question. Was the Win98 drive fully connected in the caddy, when you loaded XP to your new hard drive?

  griffo 15:39 25 Jun 05

Yes it was.

  LastChip 15:42 25 Jun 05

Go into Device Manager and see if your "caddy" drive appears there without any problems.

ie. This device is working properly.

  griffo 15:46 25 Jun 05

Yes, it is stated as 'working properly'.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…