No display on monitor, help please.

  imperial4cereal 20:57 01 Mar 08
Locked

When I turn this computer on I don't get any bios or anything on the monitor. Recently the pins on the processor got bent due to a massive heatsink not attached properly, they were bent back to make it fit. Could that be the problem? Does a computers system bios not load of the cpu us faulty? If not then where could the problem lie. I'll try and reply as soon as I can if more info is needed. Thank you in advance.

  imperial4cereal 21:17 01 Mar 08

Or could something be up with the video card, its an 8800gt with 2 massive fans attached that were bought seperatly.

  Fruit Bat /\0/\ 21:31 01 Mar 08

FAns running? Les lit Hdds clattering?

  wee eddie 21:31 01 Mar 08

Are you sure that all the pins are straight and in their right holes?

  imperial4cereal 05:00 02 Mar 08

I'm pretty sure there all strait, I took my time with that or else the cpu wouldnt sit right at all or at least it wouldnt with mine, but I'll doubt check thanks. About the fans; the cpu fan is going, the fan on the powersupply runs and the fan connected to the video card is running. Also theres a red light on the mobo that stays on the entire time the computers turned on. If that helps any.

  Arvind 10:49 02 Mar 08

I have the same problem where the computer turns on ,fans running no display on monitor.i have changed to my other monitor which i know is working but no joy.I dont get the post beep.can anyone help>>>>>>>>>>>

  Fruit Bat /\0/\ 10:57 02 Mar 08

Start your own thread do not hijack someone elses thread.

HateBreed86
is the CPU getting warm?
does the hard drive run?

if none of above then CPU probably u/s

  imperial4cereal 19:57 02 Mar 08

I'm fairly certain that the hard drive is running, but I'm going to try it with a brand new one tonight just in case. And I'll check too see if the cpu is getting warm. Can I just take the heatsink off it and run it w/o? I'll make sure to post back when those 2 things have been tested. Thanks.

  mrwoowoo 20:19 02 Mar 08

For heavens sake don't run the cpu without the heatsink or it may fry .
Perhaps the heatsinc not being seated properly has damaged the cpu due to overheating.The system should, if all is set up right, shutdown before any damage is done.
Download and install this,(free) ,to keep an eye on cpu,gpu and mainbpoard temperatures.

  imperial4cereal 21:10 02 Mar 08

thanks for the heads up. Its a different heatsink now. The first one had to be replaced. Gonna try with a different cpu of the same socket type as well.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Method Studios' title sequence for BBC series Taboo is truly unsettling

Best Pages for iOS tips | How to use Pages for iPad & iPhone: 6 simple tips to get more out of…