No boot device

  rawprawn 11:10 24 Dec 05
Locked

Last night I closed the computer as normal with no problems. This morning when I started up I got the above message, I tried to reboot twice with no luck. I looked in BIOS and it wasn't finding the primary drive, I tried rebooting again and it worked and booted as notmal. I looked in Event Viewer and it said "MSInstaller unexpected or missing value" then a long registry ref which I have been unable to find. I have run sfc, and it asked for about 10 files to be copied to the dll cache, I ran CHDSK which showed no problems.
Does anyone have any ideas as to what may have caused the error?

  Gongoozler 11:31 24 Dec 05

Hi rawprawn. I can't say what caused the problem, but as even BIOS couldn't find the drive, I think you should back up everything important and be prepared for a drive failure.

  madPentium 11:36 24 Dec 05

If the bios doesnt see the drive, you wont be able to back anything up. The only hope you have is to put the drive into another pc and pray it detects it. In the other pc, hook it up as secondary master. You may have to disconnect a cd to do this, but just copy what you want over to the C drive, switch off, remove your drive, hook up the cd/dvd burner and switch back on so you can backup.

  rawprawn 11:43 24 Dec 05

Hi, The bios is now seeing the drive and it shows "Healthy System" in Disc Management. I have now rebooted about 6 times with no problem, I have backed up everything to my second HD (Idid that yesterday using Acronis) Everything now seems normal, but at least I am now ready if the HD fails. What I don't understand is if there is a problem with the drive wouldn't it show in chkdsk?

  Gongoozler 12:41 24 Dec 05

Hi rawprawn. I've been trying - unsuccessfully - to find where the basic data on a hard drive is stored. I would guess it's in a chip on the drive circuit board. Wherever it is, it's quite probable that occasionally, but fortunately rarely, the data transferred to the computer BIOS can be misread. This happens in other places in a computer and causes mysterious crashes etc. As long as it remains a rare occurrence it is usually dismissed as one of those things that computers do. If it gets more common, then it can be indicative of impending failure. What can also happen is for the MBR on the drive to become corrupted. and this can result in several files being reported as missing or damaged. My understanding is that with the NTFS file system this is sometimes self repairing. This sounds like it could be what has happened in your case. I'm no expert on any of this, so hopefully someone will tell me if I'm right or if I'm talking complete rubbish.

  rawprawn 13:09 24 Dec 05

Hi Gongoozler, thank you for that explanation let us hope it is one of those rare occurrencies.I was good of you to take the trouble to try and find out. I have now rebooted about 10 times and all seems well. The only thing I have found that is in any way suspicious is that I run a program called Folder Access in which I keep financial data. That wasn't working and I needed to reinstall and reboot to get my info back. I have had some problems with this in the past and I suspect that it may have a bearing althouh I just cannot see it stopping Bios seeing the HD. Anyway I will tick this as resolved and see what happens.
Have a very Merry Christmas.
Dennis

  Gongoozler 14:14 24 Dec 05

And a Merry Christmas to you too Dennis. While trying to find out more about hard drives I came across this site which you might find interesting click here

  rawprawn 14:25 24 Dec 05

Thanks for that, I will have a good read.

  Diemmess 18:10 24 Dec 05

Gongoozler
Thanks for that, I too will have a good read.

For what it is worth :- I occasionally had the same refusal to boot while using Win98SE.
The message(from memory)was 'no boot disk found.'
I simply rebooted in panic and disbelief and the second attempt - was normal.

I still have the same computer, but use Win 2000 now and have a larger HD in place.

I don't think the panic ever went to far as to have me look in BIOS, but as I say it was rare and only occured at first switch-on from cold.

  woodchip 18:17 24 Dec 05

Constantly using Hibernate and standby can create these kinds of problems. That;s why it's good to shut down by means of start button

  rawprawn 18:21 24 Dec 05

I always shut down each evening, however If I am out during the day I leave the machine on and it does go into hibernation after 1 Hour. Should I extend the hibernation time?



Diemmess, mine was also from cold this morning, but all seems well now. (Knock on wood)

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…