no activity on laptop

  Steve C 12:39 30 Jun 05
Locked

ive been given a IBM thinkpad T21 that wont work and if i can get to work will be ideal for my daughter for her school work. All that happens is that when its switched on the IBM logo comes up and the words press F1 for IBM THINKPAD BIOS SETUP UTILITY and press F12 TO CHOOSE TEMPORARY BOOT DEVICE nothing else no whirring hsrddrive just the sound of the fan operating.Has any one any ideas whats wrong.
I think the mainboard is U/S would it be worth getting it fixed
THANKS

  Completealias 12:44 30 Jun 05

Don't think it u/s as at least your getting something go into the BIOS and check the boot settings and see if the hard drive is recognised etc.

Could be either hard drive isn't recognised in which case set to autodetect if still nothing hard drive could be knackered. Boot settings could be wrong I would go with 1 removable device 2 hard drive. Try booting with a boot disk

  Taff36 12:50 30 Jun 05

I don`t know how old it is but the last laptop I was "given" suffered from the usual problems - the battery had all but expired. They are relatively expensive to replace too. My Compaq laptop battery costs £110 to replace for example. If your battery was flat when you got it I suggest you leave it on charge for ar least 4 hours and try again. Repairing laptops really depends on what`s wrong with it and spare parts are prohibitively expensive in comparison to buying a new computer. Let`s find out a bit more first though.

What happens if you choose either of the options you mention?

  Steve C 13:00 30 Jun 05

battery ok nothing happens when you press F1 or F12
cant seem to access bios at all

  Steve C 13:08 30 Jun 05

wont boot from boot disk

  Fruit Bat /\0/\ 15:25 30 Jun 05

Had a T30 recently with same problem hard drive had become loosefrom connection.

Maintenance manual at click here shows how to get at HDD.

Good luck

  Steve C 17:10 30 Jun 05

no harddrive fitted have ordered a new one + caddy
will let you know if it works

  Steve C 13:10 04 Jul 05

have fitted new harddrive but still no response
any other ideas
please

  Steve C 13:16 04 Jul 05

have fitted new drive still no activity

  Steve C 13:16 04 Jul 05

have fitted new drive still no activity

  Completealias 13:22 04 Jul 05

Can you get into the BIOS yet?

If so check that its set to auto detect hard drives, did you fit a new internal drive?

This thread is now locked and can not be replied to.

Amazon Fire HD 8 review: A brilliant combination of function and value – with one massive caveat

1995-2015: How technology has changed the world in 20 years

How to create an introvert-friendly workplace

Apple Watch Series 2 review | Apple Watch 2 review: New Apple Watch is faster, brighter,…