No access to Com 3

  Alkan 06:59 09 May 04

I have just reinstalled Win. ME on my machine,
All programs, files and settings reinstalled perfectly except for access to Com 3 were my modem is sited. Device Manager states the my modem is working correctly( no yellow exclamation mark). Modem test in Safe Mode confirms modem registry entry correct and hardware correct but cannot access Com 3.
When I try to dial up my ISP the message states that there is anoyher program using Com 3.
I have tried to find this program, without success.
My question is: How can I find out what program it is and remove it if possible or should I change my port setting for my modem maybe to Com 1 and if so,How?
I would be grateful for any help and advice.

  Valvegrid 07:22 09 May 04

I'm not sure about Win ME, but do you have a program, the same as in Win 98 called System Information? If you do it's located in System Tools.

If you have this program, open it and open Hardware Resources, then look down the list for IRQ's and open it. This will give you a list of all the hardware and what IRQ it's using and what it's sharing with. See if you can see either the modem or COM3 in that list, you should see who the culprit is that it's sharing with.

  Valvegrid 07:27 09 May 04

BTW, if you have any spare IRQ's, go back to Device Manager and try changing either the modem or the culprit program to the spare IRQ. If you have none, there are other ways of getting around it, just post back, but one step at a time at the moment.


  Alkan 08:14 09 May 04

Thank you for your quick response to my query.
I have tried the following:
Under the IRQ's in System Information, IRQ3 has MDP3880-W(B)PCI Modem Enumerator (status) OK,
under Conflicts/Sharing, IRQ3 has the modem enumerator and also ACPI IRQ Holder for PCI IRQ Steering ??.
In Device Manager only Com1 is listed under Ports even though there are 4 Com ports on the computer.

  Valvegrid 09:05 09 May 04

I have to go out now, but I have had this problem a few years back and this information seems to come to mind: click here

  Alkan 17:22 09 May 04

Thanks for the link to the info about IRQ Steering. Tried all tests and all past. According to Norton Diagnostics and Sandra Standard there is a program that is blocking access to Com3. I've tried anti-virus and Spybot and AdAware and none turn it up, maybe the only thing left is to reasign the modem to Com1 could you please help with this. Thanks Alkan

  woodchip 17:26 09 May 04

Delete the modem in control Panel and install through the add hardware wizard it allows you to set the port if you do it right have your drivers ready

This thread is now locked and can not be replied to.

How to watch Windows Event live stream, live blog | Microsoft event live stream: Watch Microsoft…

1995-2015: How technology has changed the world in 20 years

This amazing app turns your iPad Pro into a Cintiq

iPhone 7 Plus review: A superb big-screen phablet, but the price tag's enormous | iPhone 7 Plus…