New Router - Slow on One computer

  mge091 21:49 PM 19 Jan 13
Locked

Hi Everyone,

I just got a new wifi router, my old one crapped out. I went with a Linksys N300. Since hooking it up though one of my computers is getting terrible connection speeds. For example, a standard ping to returned with these speeds: 1631ms 43ms 590ms 38ms

In that order. Does anyone have any thoughts as to what I could do? I had zero speed issues with the old router.

Thanks!

  difarn 10:18 AM 23 Jan 13

Have you made sure that the firmware of the router is up to date? To do this you need to get onto the router admin pages. Firmware update here.or you can do it via the router.

Is your wifi adapter driver on the "slow" pc up to date?

Is it slow if you try another browser?

What are the speeds like on this PC when you connect by ethernet.

Your router is wireless-n and this could be causing the problem with your slow pc. The attached article may explain this to you - particularly look at Fix 3. It may be that you will have to change the type of security on the router connection.Have you set up the wireless connection on the slow pc to take account of the kind of wireless standard your network will support - e.g. mixed mode or b/g instead of just n. Your router manual explains this under wireless basic settings - you can get a copy of this from the link I have posted above.

Advertisement

This thread is now locked and can not be replied to.

How to watch iPhone 6s, iPhone 6s Plus launch live: What to expect from Apple's 9 September 2015…

1995-2015: How technology has changed the world in 20 years

Swedish schoolkids use Minecraft to redesign Stockholm city centre

Apple's special event invitations decoded: A look back at 13 of Apple's most cryptic invites