New install 98se - 640x480-16colours only choice ?

  greybeard 18:01 10 Apr 08
Locked

I've just done a clean install on an IBM Thinkpad type 2647 of 98SE.
From the beginnings of the windows setup, I noticed the resolution was very low, but I assumed that could be corrected afterward.
No, the screen properties/settings tab only allows 640 x 480 16 colours.

During the setup, there was a question about pci settings which I think mentioned previous settings, but I clicked OK which I think was in answer to not keeping earlier settings/drivers(?).
Originally the hdd had xp on it, so I assumed that re-formatting the drive would have erased these anyway, and all the new pci card drivers would be on the 98se disk.
I've got Everest loaded, and that tells me there is a S3 Savage/IX+MV (86c294) on the PCI display entries, but in device manager, under display adapters it's only got "Standard PCI graphics adapter(VGA)" and no mention anywhere of the savage card (if I've interpreted that correctly )

I'd be grateful for some advice to steer me through this please.
John

  greybeard 18:03 10 Apr 08

I should have added that in the Device Manager, all the PCI devices under the "Other Devices" tab have an exclamation mark on them.

  Fruit Bat /\0/\ 18:41 10 Apr 08

I assumed that re-formatting the drive would have erased these anyway, and all the new pci card drivers would be on the 98se disk.

you need to load the drivers for your motherboard and graphics card.

  Totally-braindead 18:43 10 Apr 08

You need the drivers for the Thinkpad.

What you are seeing is because its using windows own drivers which are just designed to get you up and going.

If you have the disk install them, if not click here mind you I couldn't find a 2647 mentioned.

  Sea Urchin 18:47 10 Apr 08

Using the search box on the Lenovo brings up the 2647

  Miké 18:56 10 Apr 08

I think these click here are the correct S3 Savage drivers.

USE AT YOUR OWN RISK.

  greybeard 21:16 10 Apr 08

Previous post just disappeared when I clicked on "post response" and I had to log in again.
I'm getting really fed up with the lack of auto login( see other thread- and yes, I have been in contact with FE)
Rant over.

Thanks all.
Lenovo site has lots on the correct model, but nothing specific to drivers for the graphics.

I've downloaded the Savage driver, and will install later this evening.

John

  greybeard 21:46 10 Apr 08

It worked perfectly, made so much easier by my new flash drive toy ;)
John

  woodchip 22:04 10 Apr 08

You need to get all the Win98se drivers and load them for the laptop, or you will have nothing but trouble

  Miké 22:21 10 Apr 08

Your welcome John.

  greybeard 22:21 10 Apr 08

Thanks for making the point woodchip.
How do I go about it, as I assumed the other drivers were on the set up disk ?
Do you mean the pci problems I mentioned above, or do you mean getting the latest drivers ?
At the moment the laptop is off line, and that is planned to be the next step in getting this other laptop up and running.

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Fresh New Fonts of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced