New Hard Drive - Now have very slow start up

Installed a 2nd HD last night which is working fine once the pc has booted up - thanks to the people here who helped out when I hit a problem!!

Problem is that my PC now takes an age to boot up - firstly stays on the XP start screen for a couple of mins (the green bar moves so its not hanging as such), then get a blank screen for about 20 secs, then onto the desktop which takes a further couple of mins to add all the icons etc.

Is there anything obvious that might be causing this? As I said the PC works fine once its finally up and running.

Thanks

  THE TERMINATOR 23:14 01 Jun 04

Have you defragged your new drive yet, this may help. TT

  hugh-265156 02:19 02 Jun 04

i have no idea sorry but some things to try.sorry if you know this already.

if you have just added it as slave i cant see how this would slow things down at start up.setting my drive info in the bios manually or setting to auto detect has no added time effect that i can notice so i doubt its that.

if its a new C: drive and you have transfered data from the old one to it or freshly installed windows on to it then as above run defrag maybe.

how many programs auto start with windows and show in the tray at start up? has the ammount of start up programs changed recently?

if there is a lot loading with windows maybe you dont need them all and can disable some from auto loading,this will speed things up a bit.they will still start when you want them by clicking the programs shortcut icon or choosing them from the start menu as normal.

try clicking 'start/run' and type 'msconfig' then click the 'start up' tab and untick everything except your AV and firewall as you want these to start with windows. restart and tick 'dont show again' when you get the warning that you have changed the way windows starts.

you can look up things listed in 'msconfig/startup' if you are not sure what they are before unticking them click here you can always put the ticks back if something doesnt work.even try unticking everything and if its faster put one tick back at a time(restarting each time) to test.when it slows down you may have found the culpret.

try also disabling uneeded services that load at start up to speed things up some more click here the safe list gives me no problems and saves a bit of ram.

try bootvis click here install it and click 'trace/next boot +driver delays' and restart. allow it to load at start up and you will be presented with a graph of everything that loads at start up and the time taken for each thing and overall boot time.

next click 'trace/optomize system' and restart again. allow it to run and when the pop up box disappears its done(may take a few mins) start up should be a bit faster now.

Thanks for the suggestions huggyg71.

I agree, all I've done is add a new HD as slave so don't know why it should effect the start up process so much. I had already cut back the programs that load on start up to a bare minimum and this hasn't changed so don't think it's that

Will try bootvis later and see if I get any joy there.

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…