New ATI Radeon drivers won`t install

  Actor One 23:21 10 May 03
Locked

Please help someone - I`m pulling teeth out as well as my hair.

I have recently bought two games Postal 2 & Freelancer and on loading they both say by video display driver needed updating. Now even ATI says that if it ain`t broke don`t fix it, so I ignored this with Freelancer but couldn`t with Postal 2 as it persistantly crashed to the desktop.

So I have downloaded the latest Drivers for the Radeon 8500 (mine is 6.13.0010.6166)to the current one (6.14.01.6307) but on no fewer than 4 occasions, each time to a different file location, and each time I try to update the driver from any of those locations the hardware wizard tells me that that it cannot continue the update as it can`t find a better match than the software installed, Why is this?
If I tried double clicking on the download, I get a brief blue screen with white text (for less than a second so I can`t read what it says) and it then reboots with a Microsoft Critical Error message which tells me was caused by a device driver!!. Going around in circles. I`ve followed ATI`s installation instructions too, uninstalling my driver first, but I get the same Hardware error messages. ATI is useless as they don`t have an e-mail helpdesk, just FAQ`s. Why can`t I get the damn thing to install.

  rubella 15:58 11 May 03

for all things radeon:

click here

click here

  hugh-265156 16:06 11 May 03

follow the sticky on how to remove ati drivers click here and freelancer requires direct x9 i think to work correctly alough the demo worked ok for me using 8.1

  Actor One 20:26 13 May 03

Just checked my responses - Thanks to Huggy & Rubella, I already have DirectX9 on as you can`t run Freelancer without it, Postal 2 went on 2 weeks later, I think it is the drivers, so I`ve downloaded them again - 5th time making sure everything else is off, firewall, virus checker, crash preventer etc. But I`m not going to attempt to change the driver unless abosultely necessary. I seem to remember in the distant past something like this happening and then suddenly I did something and the new driver installed, though can`t for the life of me remember what I did....!! Thanks for the rage links too, but they don`t work (DNS Errors).

  tintin1943 15:18 11 Jun 03

I have a K7VZA m/board ver 3.2
ati graphics card voodoo2 banshee rage 2
I have 16 bit colours and good screen res.
but cant get the AGP bit to work.?
any helpers out there

  Actor One 14:04 12 Sep 03

Thanks to all that responded have been away recovering from an operation hence the delay in responding - solved the problem: I was downloading the wrong drivers - should have gone to the Powered by ATI site not the ATI site itself, went to the Sapphire site, clicked on drivers, this went to another site in ATI downloaded the correct & newest version driver & Catalyst control panels, placed them in a temporary folder, and voila they even both have a setup.exe which installs them for you, without having to delete the older drivers first. Things work fine now....except that Postal 2 crashes for a different (known) reason...an infinite loop....!!!

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…