Networking on workgroup MSHOME

  Rayspan 19:58 01 Nov 05
Locked

Looking back over forum threads, this is not a new prob, but no-one seems to have come up with a definitive solution.

I have set up a home network for my daughter between two machines, using a wired ethernet LAN connected via a Netgear DG834 ADSL modem with 4 port hub.

Both are on workgroup MSHOME, but neither machine sees the other. When viewing the network, one system offers: 'MSHOME is not accessible. You might not have permission . . . et.c.' The other just shows itself.

BTW both machines connect flawlessly to the web, which seems to rule out cable/hardware faults.

Particularly annoying this, because I have the same router at home and setting up the LAN was dead easy.

  scotty 20:19 01 Nov 05

Could be a firewall not configured correctly. Try temporarily disabling all firewalls. If this allows you to see other computers then post back with details of firewalls being used and someone will explain how to configure them.

  Rayspan 08:59 02 Nov 05

Thanks Scotty - yes I tried that. Firewalls aren't needed anyway, Router has one built-in. Problem may be pass-word related, still investigating.

  mgmcc 09:16 02 Nov 05

Have you actually set at least one folder in each PC as "Shared" in its Properties by right clicking it and selecting the "Sharing & Security" option?

<<< Both are on workgroup MSHOME >>>

Although there is no logical reason for it, changing the workgroup name from the default MSHOME to a name of your own has been known to overcome networked computers failing to see one another. Give it a try.

Open "My Network Places" and use the "Search" facility to see if it can find the remote PC either by its name or by its IP address.

If one or both of the PCs is running XP *Professional*, have a look at this article about the need to have identical Account logins in both PCs. click here

  mgmcc 09:19 02 Nov 05

If all else fails, something which might help to get the two talking for file/printer sharing is to use "IPX/SPX/NetBIOS Compatible Transport Protocol". This doesn't need configuring with IP addresses and so on like TCP/IP and isn't affected by firewalls. However, for internet access, TCP/IP is still required.

To install "IPX/SPX/NetBIOS Compatible Transport Protocol" in Windows XP, go into the Network Connections folder, right click the Local Area Connection and select Properties. In the General tab, click the Install button. In the next box, highlight Protocol and click Add. Select "NWLink IPX/SPX/NetBIOS Compatible Transport Protocol" and click OK.

In Windows 98, in Network Properties (right click Network Neighborhood and select Properties), click the "Add" button. In the next box, select Protocol and click "Add". In the next again box, highlight Microsoft in the left window and then IPX/SPX- compatible Protocol in the right window, then click OK. Back in the main Network Properties, highlight the IPX/SPX entry that relates to your network adapter and select Properties. In the NetBIOS tab, tick the box for "I want to enable etc.." and click OK. With Windows 98, you will need to reboot the computer after making changes to the Network Properties.

  Freddog 09:21 02 Nov 05

Do whoat I wanna do get my router network card whole lot of computers and SMASH em' REAL bad then burn the bits of crap into metal dust!!!!!!

  kjrider 09:33 02 Nov 05

Have you installed the networking properly?

Did you set up the main PC and do a 3.5" floppy to set it up on the other PC?

What OS are you using? XP seem to be the easiest to set up with its little wizzard.


Try uninstalling and restalling it.

Have un

KJ

  Rayspan 14:48 02 Nov 05

Thanks for responses everyone. Yep, shared folders set up and file & print sharing enabled. Both their systems are on XP Home. As you say kjrider, it was dead easy to network mine and my wife's systems. Since exactly the same O/S & router are involved I didn't expect a problem. I'll try all these ideas, unless I get a hole in one! I should be so lucky. Will post outcome.

  sawest 15:41 02 Nov 05

Sounds like you have an IP address/Subnet Mask issue.

Try this:

On the machine(s) that will not connect click Start > Run > Type CMD and hit Enter (for Win98 type Command & then Enter). At the command prompt Type ipconfig /release_all then hit enter, then type ipconfig /renew_all close the command prompt window then try to connect to any of the networked machines through My Network Places (XP) or Network Neighberhood (98).

  sawest 15:42 02 Nov 05

Sorry, forgot to say hit enter after typing ipconfig /renew_all

  Daveboy 21:29 02 Nov 05

same here !

I had a similar problem recently, I had a response from "Lastchip" that cured it for me:

OK, try this but be careful.
I, like our Forum Editor, am reluctant to post Registry Hacks, because they can go wrong - Big Time, but sometimes, it is the only way to overcome a problem. So please read this with care and follow the instructions precisely.
CAUTION: DO NOT CHANGE ANY SETTINGS EXCEPT AS INSTRUCTED.

On your XP MACHINE:

First: Go to Start; Run; and type; regedit [OK]

Navigate to;

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa

and look for a DWORD restrictanonymous and see what the value is. If it is anything but 0 (zero), close regedit to follow the next part of this post. If it IS SET to 0, this post no longer applies and it isn't the root cause of your problem.

Next, go to System Restore and make a backup of your system, in case things go wrong.

Now, reopen regedit and as a further backup, go to Registry (top left) Export Registry and save a copy of your registry to the root drive (C:). This is a further safety net should the need arise. I don't wish to frighten you and with this hack, things shouldn't be a problem, but you can't be too cautious when dealing with the registry.

Finally, navigate back to restrictanonymous (as above) RIGHT CLICK the DWORD, select MODIFY and change the decimal value to 0 (zero).

A further word of warning, there is a DWORD restictanonymoussam just below the one you want - DO NOT change this.

Now close regedit and reboot your computer with your fingers and toes crossed ;-) and all should be well.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

The Pantone Colour of the Year 2017 is Green

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…