Networking with Win 98Se and Win XP

  mackaycc 00:01 21 Feb 04
Locked

What is the best way to go about networking two computers which have the above operating systems? The main reason for this is to share the broadband connection on the XP Comp but also want to be able to share files.

Any help will be appreciated.

  temp003 01:42 21 Feb 04

click here for a step by step guide.

  Gaz 25 01:47 21 Feb 04

Wireless networking is a little annoying with 98, it doesnt communicate well. After a few updates it does though.

  mackaycc 15:30 21 Feb 04

What I'm really wanting to know is what exactly am I going to have to buy to get this done? Do I need to get a network card for both computers or is there an easier way of doing it? Also what problems am I likely to habe due to using different operating systems. Would I be better off putting XP on the 98 computer?

  temp003 02:22 22 Feb 04

I assume your XP computer is the one with the internet connection, which is to be shared with the 98 computer. You can think of the XP computer as the "internet connection server".

You will need a free network card on the XP computer (so you may need to get an extra one if the existing one on XP has been used for the broadband connection), a network card on the 98 machine, and a cable to connect the two machines (assuming only 2 computers to connect). Make sure there are free PCI slots on the machines for the network cards.

The most common network card is the 100 Mbps ethernet card. Then buy an ethernet crossover cable to connect the two computers via the network cards. Make sure it is a crossover cable.

Install the network card on each computer. Connect them using the cable and configure the two computers using the link above.

Sounds an expensive exercise to upgrade the 98 machine just for the internet connection, but if feel that the 98 machine can otherwise benefit from an XP upgrade, that's fine.

  mackaycc 16:44 29 Feb 04

I'm having real problems getting this network set up at the moment. I have set up the network cards in both computers and installed them, connecting them through the crossover cable. On the Win XP computer it picks up on the network and tells me that the LAN is now connected, but although it connects, no other computers are visible through this one.

On the Win 98 Computer, the other computer on the network gets picked up and you are able to view what is on the XP computer through the 98 computer but not vice versa. The only problem with the 98 computer is when you try and set it to connect to the internet through the XP computer and it throws an error. I am hoping this will stop when I get the XP computer to see the network.

Anyone have any ideas on how I can set this up properly?

An help much appreciated.

  spikeychris 16:49 29 Feb 04

First thing first (Peter Kay gag)

Check that the XP machine has its firewall turned off. Make sure you are logging onto Win98 as a user, IE: create an account, don't just switch on and use.

  mackaycc 18:08 29 Feb 04

The firewall is turned off on the XP machine and the 98 machine has a user specified. I have made everything on both computers shared for the moment but although the 98 computer can see and access everything on the XP computer, the XP computer does not seem to even be able to see the 98 computer. The only problem with the 98 computer at the moment is that when I try to set it up to access the internet through the XP computer, it gives me the following error: "Cannot get configuration information about your computer because of the following error: Error 12009 occured".

  mackaycc 16:49 05 Mar 04

I'm still having dificulty in getting this network set up. Does anyone have any more ideas on how I can get this working?

  Ivor_Monkey 17:35 05 Mar 04

You have disabled firewalls and have a good connection. So you've done the difficult bits.

It is not very sophisticated, but have you tried rebooting both machines?

  pipedream 18:02 05 Mar 04

Have you enabled internet connection sharing on the XP system? To do this... Control Panel > Network Connections, then right-click the icon for your broadband connection, select Properties > Advanced, then tick the box next to "Allow other network users to connect through this computer's Internet connection". Also, on the 98 PC in Internet Properties, "Never dial a connection" should be selected.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac